summaryrefslogtreecommitdiff
path: root/dev-python/pylibacl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/pylibacl
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/pylibacl')
-rw-r--r--dev-python/pylibacl/Manifest2
-rw-r--r--dev-python/pylibacl/pylibacl-0.6.0.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pylibacl/Manifest b/dev-python/pylibacl/Manifest
index efcc009a0e0f..40cd58de9bca 100644
--- a/dev-python/pylibacl/Manifest
+++ b/dev-python/pylibacl/Manifest
@@ -1,5 +1,7 @@
DIST pylibacl-0.5.4_p20191217.tar.gz 40283 BLAKE2B dfe5baababe4cce24bc12dd61263c30160e93be7dc0625abdcad9e4daed19c5ac1ebf43351f9f5815884162258884cd8c7e2edb323ec9ce51247a43d53fea20e SHA512 6d4a84e1885a2000226f956580a8e767216d6280d4b8ae1066e6a1c1f82708d06a4f2eacc3ae45ff7ae3b122125da9fb6afbaae038e117b63cd7d91ac95e2624
+DIST pylibacl-0.6.0.gh.tar.gz 40231 BLAKE2B ba76f5540de62cec8572960b65f65289d7fe2066f76861240849c4c8175a9219b7ced086739b5a9b4d560a125c8fe759cc7b5b688bd4dc3d84ca4dc78897ea75 SHA512 a93ad199d9946490a863906411893a204bf801df71cf70217d6b29940a9365f05fd121116f22e054a3b8d27cd62e35c73566c1e0dd246ae5c0edd2f967df50ba
DIST pylibacl-v0.5.3.tar.gz 32792 BLAKE2B 005785dda2b7933ff71dd1296b1d4315a6492fc893aba56136c775f78b9aa3bd8f9d4898bbe0160fac53a306329977ddaecd073739531ba42dd0b6cc622b9eef SHA512 ea648acc3df9e1cf2fd68576b0b691a353b257d00b74fc80aa7f60089b9dbc912452ebe6b84da2930cac888b9047740530dd0e38b4d5be52c37fc6d3a29a7ce2
EBUILD pylibacl-0.5.3.ebuild 928 BLAKE2B 306b483fa1d85458b90480b771629ffd7ae18ef3dfa2a6d8084ec697e0812e13e380f1ce77cbcbf34082aab983fa0937fe71707d0f02d348dc2ea6ad4c3945e2 SHA512 496633a731bbe0c05b7350ff14ed644039a48f9c2d55e317dabd3cebc36ea08e17fa8b4e38d1acaa324ba674944b99cdd8181ccff9f30998efc84db752c9f97e
EBUILD pylibacl-0.5.4_p20191217.ebuild 1009 BLAKE2B e2a5a73bc61d3243b26c115a7e7945260e59a9bedaddbf88affb5bdf5c8348d3db4d200afb96113f6ac05b87b825bd74f8f672d3aca0ab25e6516377cdf36cda SHA512 ea5e810818be787556024c6264572ef32a0dfa0c3013f857186586545c668cbc7bd24ee1b8430e632abf1ff06bbc8a71f6b4ab3388137472c347f9521cac7949
+EBUILD pylibacl-0.6.0.ebuild 916 BLAKE2B ceda85abf946e016856f5cb7d555c79527e132ed4fc1279c55d41a9f81101bc1c17c1e10151f7b1ae63f5773df2565acbd5d0d0888dbca3748c5d725566e3571 SHA512 b601d44f42c0f31411ed3397cc421c2d7607b6cb0f5a15810a97802f462d369ea5fcad706a5a71dfcce6b90375b11657e20bd76ef9017f0c7b87c99d3359a6b6
MISC metadata.xml 445 BLAKE2B 01fa6d3dbb4f640a84c7cde4fc2c0c2691345fde557c7d26af9b5aaf5f64ee281a9c50eb273471ef3ec1a4c7cdfd8b48bccfdf3e50804f88981353a7a5433ce8 SHA512 b5fd28a88149cc0afb3535daa5c5e8f67f137e98c0671595a381d9d748212ed93a3226339b4999c7cfce1779fa6fa0cf568f38610ef77fed685e62dff9f9a344
diff --git a/dev-python/pylibacl/pylibacl-0.6.0.ebuild b/dev-python/pylibacl/pylibacl-0.6.0.ebuild
new file mode 100644
index 000000000000..5b4469c6178c
--- /dev/null
+++ b/dev-python/pylibacl/pylibacl-0.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="POSIX ACLs (Access Control Lists) for Python"
+HOMEPAGE="
+ https://pylibacl.k1024.org/
+ https://pypi.org/project/pylibacl/
+ https://github.com/iustin/pylibacl/"
+SRC_URI="
+ https://github.com/iustin/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="sys-apps/acl"
+DEPEND=${RDEPEND}
+
+distutils_enable_tests pytest
+
+python_test() {
+ if ! pytest -vv; then
+ eerror
+ eerror "If you got the following errors:"
+ eerror "\"IOError: [Errno 95] Operation not supported\","
+ eerror "then you should remount the filesystem containing"
+ eerror "build directory with \"acl\" option enabled."
+ eerror
+ die "Tests fail with ${EPYTHON}"
+ fi
+}