summaryrefslogtreecommitdiff
path: root/dev-python/pylibacl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pylibacl
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pylibacl')
-rw-r--r--dev-python/pylibacl/Manifest5
-rw-r--r--dev-python/pylibacl/metadata.xml14
-rw-r--r--dev-python/pylibacl/pylibacl-0.5.0-r1.ebuild35
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pylibacl/Manifest b/dev-python/pylibacl/Manifest
new file mode 100644
index 000000000000..8778c543bca9
--- /dev/null
+++ b/dev-python/pylibacl/Manifest
@@ -0,0 +1,5 @@
+DIST pylibacl-0.5.0.tar.gz 23886 SHA256 8706291e815547e2e89426508d00fd31d437bdb8e5eb9407777f414b0606e2d6 SHA512 c12390b6a0ca73fd351b84860a9d68d74126dbcd8656916d677a39002a6e4abbac704d450b0b0118bba40987cdd11cc11ad14008de39dac8dc9ca7587ae54c46 WHIRLPOOL e6496a45f81f9bb12bff33f7724768f768a9ad1936ea6efd358fff1ac1ecb8ba1bd662c22b8ce6b9e4cfa879ed32bec5dc4c288fb025960e2e81e5236065c07a
+EBUILD pylibacl-0.5.0-r1.ebuild 937 SHA256 e9bb81fd7c543c62a02a8eb670d1a4531420e68d388c371ec0c692efabf15a14 SHA512 99aed07f81908463d6866460c4b439a5f9b364cbcb3659fc3a7906ec68bb79d38562639536d6df8f6df724ebd521f14fc1529a1805105a547f939e450f6038d2 WHIRLPOOL 8f84646217e3161ce5820fc46363bc4fbf4f66150b16b2a187dcb1788e3ec1b7a48d190a3f1e94ed2c4bb6a079b2a658ab05decf944137030c63d404e6589a6d
+MISC ChangeLog 2833 SHA256 c3ca52b632476698260e311949eb707f9ed9b10ab5a6d30bc16090b92141b147 SHA512 111bc1513f0d987f602723e1934ef0f611c84a378f9b6a9dc4f1ea9cb36d79d064dbcdc29a9c3b426893b4aa43aee22c8fdb0e852a553b7f92d68b67f63b6ad9 WHIRLPOOL 3cffb8058e88aaeac8b37bca59ba9258bb48c7e4bc6ac94dcd5622a87c2c79bebd67e016a7ce0191ee453155f5d06f0fb6902c234b0afa698c41fa9a5824c279
+MISC ChangeLog-2015 5683 SHA256 6fc872e31905872b3d1dda98d8aaecfd89eefdb412aa9d54416be42d2c023d00 SHA512 2ff2e1ae6c398c4623b898fe763cf8260764305dc00a54168a4661f1a2ce574a51ec713a1c528b05594f136003784f0e27694fb538fcb3a7c22650b93d10c632 WHIRLPOOL 5c24ad88870b2bc2d926c8350b86015ffb14b4e40cb491e97d9f70090d324c013fed6c4245a16988b165f1182d4de9e6112eda96717e8d9678fc0db091de767f
+MISC metadata.xml 397 SHA256 81399d55cd4eaeffa646b5dc6a5b28a62d85805dfd5f108ecbad37a20f9b2052 SHA512 c180079a6f20e899a3fe472db2e91c36ae7cf9d67f519dea0f2367aaa7febe3123374d3f5bb847267b5b42e234fe1548208db0eee20cf520ff5eb9b9cc699696 WHIRLPOOL 469bc2b5a4f06cdb520aa7a38ff59605d2d420b385f47959daa026bb56990452de2d10d8207f4c9a6ce3315493d81f46fa7cacf0b5ffaa72d6748bbc80a8f140
diff --git a/dev-python/pylibacl/metadata.xml b/dev-python/pylibacl/metadata.xml
new file mode 100644
index 000000000000..6112c9d184b0
--- /dev/null
+++ b/dev-python/pylibacl/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">pylibacl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pylibacl/pylibacl-0.5.0-r1.ebuild b/dev-python/pylibacl/pylibacl-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..3adbe818e9f7
--- /dev/null
+++ b/dev-python/pylibacl/pylibacl-0.5.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="POSIX ACLs (Access Control Lists) for Python"
+HOMEPAGE="http://pylibacl.k1024.org/ https://pypi.python.org/pypi/pylibacl"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86"
+IUSE=""
+
+RDEPEND="sys-apps/acl"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# Tests are missing in the tarball.
+RESTRICT="test"
+
+python_test() {
+ if ! "${PYTHON}" test/test_acls.py; then
+ eerror
+ eerror "If you got the following errors:"
+ eerror "\"IOError: [Errno 95] Operation not supported\","
+ eerror "then you should remount the filesystem containing"
+ eerror "build directory with \"acl\" option enabled."
+ eerror
+ die "Tests fail with ${EPYTHON}"
+ fi
+}