summaryrefslogtreecommitdiff
path: root/dev-python/pylibacl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
commit29394d0921808a94a409f01eff49f681651de5d5 (patch)
tree93d18027cb4ea68a3c967602c5793af032180bab /dev-python/pylibacl
parent5987fa693ef880163ebde423615a177cb5bda20e (diff)
gentoo auto-resync : 17:02:2023 - 08:06:58
Diffstat (limited to 'dev-python/pylibacl')
-rw-r--r--dev-python/pylibacl/Manifest2
-rw-r--r--dev-python/pylibacl/pylibacl-0.6.0-r1.ebuild (renamed from dev-python/pylibacl/pylibacl-0.6.0.ebuild)16
2 files changed, 10 insertions, 8 deletions
diff --git a/dev-python/pylibacl/Manifest b/dev-python/pylibacl/Manifest
index 3cb167ca3877..49d2fb583ea5 100644
--- a/dev-python/pylibacl/Manifest
+++ b/dev-python/pylibacl/Manifest
@@ -1,3 +1,3 @@
DIST pylibacl-0.6.0.gh.tar.gz 40231 BLAKE2B ba76f5540de62cec8572960b65f65289d7fe2066f76861240849c4c8175a9219b7ced086739b5a9b4d560a125c8fe759cc7b5b688bd4dc3d84ca4dc78897ea75 SHA512 a93ad199d9946490a863906411893a204bf801df71cf70217d6b29940a9365f05fd121116f22e054a3b8d27cd62e35c73566c1e0dd246ae5c0edd2f967df50ba
-EBUILD pylibacl-0.6.0.ebuild 939 BLAKE2B b2c4f484c3cde4b8c2ceec49444e975557d8854c26a242f873f4e00501551fb1a855f5a61b090a78b5b9f33f11b558ac4384ab2fb1b83bb9a3023c97f58de3dc SHA512 74aec9db09ecaf45d46ee1cf37ea669534236b64d54b391ad3a4d33b3406e1720d9a74c241605307a4aec54307ff233fdba9449aca7e4da84578612d3a2f6d89
+EBUILD pylibacl-0.6.0-r1.ebuild 981 BLAKE2B 09787b4157c15097c948b58835140d622e06495bbbb9df2fb71c28e7d0608c7213f542fafe915bb324cde7289e171712b9cdfc8a18dd64e1bf48f4edf9bf5eb0 SHA512 f7dbf359320d3986338c191457acb406b9c7687d2cfb4204aff5e330c418ed8889b6e3d4cee9b89a337df511074cf51d6f4d072f19a119ed5ca2be98a70d66fb
MISC metadata.xml 446 BLAKE2B 0e111cfd834a03f88984dac937b5b3d09a7675338f0381d30603b0512d7f5ae1f486a832d060ecfb9c5946c7273893ed030555062b8bd3f26f10765c28a90143 SHA512 7df5bf16220e50c851fb03af84a600eaba23fdb703aefc2586aa2d27a1e55a18ad7b117274b8a07c7d7997dfd96fd51bd2dca6d3a1dad01cacafa678a5c8a794
diff --git a/dev-python/pylibacl/pylibacl-0.6.0.ebuild b/dev-python/pylibacl/pylibacl-0.6.0-r1.ebuild
index 040aeeee24e0..d5d6d50574b7 100644
--- a/dev-python/pylibacl/pylibacl-0.6.0.ebuild
+++ b/dev-python/pylibacl/pylibacl-0.6.0-r1.ebuild
@@ -1,33 +1,35 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
DESCRIPTION="POSIX ACLs (Access Control Lists) for Python"
HOMEPAGE="
https://pylibacl.k1024.org/
https://pypi.org/project/pylibacl/
- https://github.com/iustin/pylibacl/"
+ https://github.com/iustin/pylibacl/
+"
SRC_URI="
https://github.com/iustin/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+ -> ${P}.gh.tar.gz
+"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~ia64 ~mips ppc ppc64 sparc x86"
RDEPEND="sys-apps/acl"
-DEPEND=${RDEPEND}
+DEPEND="${RDEPEND}"
distutils_enable_sphinx doc
distutils_enable_tests pytest
python_test() {
- if ! pytest -vv; then
+ if ! nonfatal epytest ; then
eerror
eerror "If you got the following errors:"
eerror "\"IOError: [Errno 95] Operation not supported\","