summaryrefslogtreecommitdiff
path: root/dev-python/pylibacl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-24 12:10:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-24 12:10:02 +0100
commit0ed86cb810f23bc360b9f8b955903db4e6595244 (patch)
tree7eb8d293be0f1777854714006cde9d7839450a2e /dev-python/pylibacl
parentb46286b28de30f0898fa7888ae7dee09db822088 (diff)
gentoo auto-resync : 24:04:2023 - 12:10:01
Diffstat (limited to 'dev-python/pylibacl')
-rw-r--r--dev-python/pylibacl/Manifest2
-rw-r--r--dev-python/pylibacl/pylibacl-0.7.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pylibacl/Manifest b/dev-python/pylibacl/Manifest
index 49d2fb583ea5..332be12976b5 100644
--- a/dev-python/pylibacl/Manifest
+++ b/dev-python/pylibacl/Manifest
@@ -1,3 +1,5 @@
DIST pylibacl-0.6.0.gh.tar.gz 40231 BLAKE2B ba76f5540de62cec8572960b65f65289d7fe2066f76861240849c4c8175a9219b7ced086739b5a9b4d560a125c8fe759cc7b5b688bd4dc3d84ca4dc78897ea75 SHA512 a93ad199d9946490a863906411893a204bf801df71cf70217d6b29940a9365f05fd121116f22e054a3b8d27cd62e35c73566c1e0dd246ae5c0edd2f967df50ba
+DIST pylibacl-0.7.0.tar.gz 47543 BLAKE2B 277c03d01ab184ffaaa2c07c56e8f2464cba8b6da0fbd251880d274bef3b27dc211f1571425d4216e02bbeba8c623edfa56cafbb27932092ffce254e6be8df5d SHA512 077515a00c7a048faf7792acd9c3e768d35674c0b3f4ec72fdf37561c90ed12bb392582a4fb9a23b7916db3375278c2636f2844f362a8335e7ad68e1e9b9c3bd
EBUILD pylibacl-0.6.0-r1.ebuild 981 BLAKE2B 09787b4157c15097c948b58835140d622e06495bbbb9df2fb71c28e7d0608c7213f542fafe915bb324cde7289e171712b9cdfc8a18dd64e1bf48f4edf9bf5eb0 SHA512 f7dbf359320d3986338c191457acb406b9c7687d2cfb4204aff5e330c418ed8889b6e3d4cee9b89a337df511074cf51d6f4d072f19a119ed5ca2be98a70d66fb
+EBUILD pylibacl-0.7.0.ebuild 927 BLAKE2B a6dd1163a399363787b2f9ddee6856a45f11891e397314647880a657e90a1e04478be12f1dd754d963e26754d23207a9d173156bf67ca13cb55422315511f91b SHA512 120b9449bf18568661cda99fef6acb301c521ab1c891d6402ccbc09166888ee296cfe80638eb11dc3028e16f37e1b656217fb2516d38496ae509f7fea83d2565
MISC metadata.xml 446 BLAKE2B 0e111cfd834a03f88984dac937b5b3d09a7675338f0381d30603b0512d7f5ae1f486a832d060ecfb9c5946c7273893ed030555062b8bd3f26f10765c28a90143 SHA512 7df5bf16220e50c851fb03af84a600eaba23fdb703aefc2586aa2d27a1e55a18ad7b117274b8a07c7d7997dfd96fd51bd2dca6d3a1dad01cacafa678a5c8a794
diff --git a/dev-python/pylibacl/pylibacl-0.7.0.ebuild b/dev-python/pylibacl/pylibacl-0.7.0.ebuild
new file mode 100644
index 000000000000..57da0be809fe
--- /dev/null
+++ b/dev-python/pylibacl/pylibacl-0.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="POSIX ACLs (Access Control Lists) for Python"
+HOMEPAGE="
+ https://pylibacl.k1024.org/
+ https://pypi.org/project/pylibacl/
+ https://github.com/iustin/pylibacl/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ sys-apps/acl
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+python_test() {
+ if ! nonfatal epytest ; then
+ eerror
+ eerror "If you got the following errors:"
+ eerror "\"IOError: [Errno 95] Operation not supported\","
+ eerror "then you should remount the filesystem containing"
+ eerror "build directory with \"acl\" option enabled."
+ eerror
+ die "Tests fail with ${EPYTHON}"
+ fi
+}