summaryrefslogtreecommitdiff
path: root/dev-python/pylatexenc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
commitb3f2504c1d05b5999b74b2135860fc721e3adf68 (patch)
treee11656067365c7d474553833d6202ed04d3324a5 /dev-python/pylatexenc
parente0fdb8199de0e7a9b7c72d7f38d2e3ddaecdacd0 (diff)
gentoo auto-resync : 15:07:2022 - 07:41:50
Diffstat (limited to 'dev-python/pylatexenc')
-rw-r--r--dev-python/pylatexenc/Manifest3
-rw-r--r--dev-python/pylatexenc/metadata.xml22
-rw-r--r--dev-python/pylatexenc/pylatexenc-2.10.ebuild19
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pylatexenc/Manifest b/dev-python/pylatexenc/Manifest
new file mode 100644
index 000000000000..52513a75a7f5
--- /dev/null
+++ b/dev-python/pylatexenc/Manifest
@@ -0,0 +1,3 @@
+DIST pylatexenc-2.10.gh.tar.gz 721836 BLAKE2B 8512e052271c127809105280360706217f5134b2349d4b21dcec720addb4cff4157173f8350115de4142aea491da2efb1a2854b4310c48ec98061470be21654e SHA512 9728731e0c84324685b77ce17fae0bea445815e2c54394d2722c4412bbd914da49280ef36b5f3a0a0346e5d2129ca2d8d3b3b92356de3c6af9eed4247cf8bd43
+EBUILD pylatexenc-2.10.ebuild 510 BLAKE2B 211fbd085a4b823308a9e3780356cac5ff0f387d39b62be7b1bd5dd16b4d1be29d66c9ff7533f05a9c17af1cb23c1067f69d3a5a34d160693b67059dd96d5350 SHA512 01fa17c632b807d62b6234136d2b2afd02d1611263152aa481747af0c3f283dd4d75aecce551a6b7227c46206d6b77a11a15f303cd9675499310b442401c0775
+MISC metadata.xml 1193 BLAKE2B 1745bdc26ce9cb63bb4ad48f77a9ffa31690be119c0a035cd6c28ea046b3e600e02bbced2d13d2a770bbb45dc7e97bfa78fb0ab6bee3d8f34cedde42b84447c1 SHA512 e4a0cbd4eb617f408ffcb40b5b08124e450edf2ccf84f4a2649f91300501fda86fdb271a5fabf7e3fc54e023a5100452c24be38ef84d2541a62d2c508524f698
diff --git a/dev-python/pylatexenc/metadata.xml b/dev-python/pylatexenc/metadata.xml
new file mode 100644
index 000000000000..539971679ce5
--- /dev/null
+++ b/dev-python/pylatexenc/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- comaintainers-welcomed -->
+ <maintainer type="person" proxied="yes">
+ <email>gaboroszkar@protonmail.com</email>
+ <name>Gábor Oszkár Dénes</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Simple LaTeX parser providing latex-to-unicode and unicode-to-latex conversion.
+ The pylatexenc.latexencode module provides a function unicode_to_latex() which converts a unicode string into LaTeX text and escape sequences. It should recognize accented characters and most math symbols. A couple of switches allow you to alter how this function behaves.
+ You can also run latexencode in command-line to convert plain unicode text (from the standard input or from files given on the command line) into LaTeX code, written on to the standard output.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">phfaist/pylatexenc</remote-id>
+ <remote-id type="pypi">pylatexenc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pylatexenc/pylatexenc-2.10.ebuild b/dev-python/pylatexenc/pylatexenc-2.10.ebuild
new file mode 100644
index 000000000000..b53dd8f95a0e
--- /dev/null
+++ b/dev-python/pylatexenc/pylatexenc-2.10.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple LaTeX parser providing latex-to-unicode and unicode-to-latex conversion"
+HOMEPAGE="https://github.com/phfaist/pylatexenc"
+SRC_URI="https://github.com/phfaist/pylatexenc/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest