summaryrefslogtreecommitdiff
path: root/dev-python/pylatex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 10:17:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 10:17:51 +0000
commite0fac29676c44b996e61c06f8d5c92288e46966b (patch)
treebe619e692a42f1a90900cca21b19a2ec88404f8d /dev-python/pylatex
parent639971d0c3ee4eef36854ab7d9729b6e8c3ac1cb (diff)
gentoo auto-resync : 07:11:2023 - 10:17:51
Diffstat (limited to 'dev-python/pylatex')
-rw-r--r--dev-python/pylatex/Manifest2
-rw-r--r--dev-python/pylatex/pylatex-1.4.1.ebuild59
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/pylatex/Manifest b/dev-python/pylatex/Manifest
index 72bdf0249b57..8e3c9add1496 100644
--- a/dev-python/pylatex/Manifest
+++ b/dev-python/pylatex/Manifest
@@ -1,5 +1,3 @@
DIST PyLaTeX-1.4.2.gh.tar.gz 307158 BLAKE2B bc20478759fc8315fd7fa2161d1638035c0dad4731c4cb254c78dfc45da2b361b3864d2ec04d6eb8fd7947e9908610eb0104444edff95666abba6a9f6da4cb4b SHA512 dcbe58de0ab715d6fbb571a7ad3981c875eacd08d06244b8715fa240df6f8f072417ae076a5caee204e000bf7eb55097b9ba49eddb5ce666470e494c15aa88ed
-DIST pylatex-1.4.1.tar.gz 301482 BLAKE2B c68c8bbf70c5099b3c3146922afe94dcf4f90bfc8644fa165ee27835f4a24642645f9849f2f9fd69656dc07dcc4807869275aacf33a1e5b9c59e539801f8e821 SHA512 55a5734e4d239cef4bcaafa0ba64eea013ba3e86d137de5a5f8311d70c949d783e2e7aad24d39d16a6febbe4bddc34e47248068e1328fe3f95f39a7c7019a3a9
-EBUILD pylatex-1.4.1.ebuild 1409 BLAKE2B 3640f58eef86b6dec0f544f3462890eee76cb9a389a707c39e38d83b2729327a4636063325c7924bb5b7e08b180a57d1f97ef5f49b1d79bd18eff0e26b634d3c SHA512 d203089ddbd5f0b9614070759ec95fc21bc35908403b05e323a4a7d4b63a2a16bf4f3aaf0bc665b0b4192c60904c3023bd745892281acf4bee599953b04fef94
EBUILD pylatex-1.4.2.ebuild 1449 BLAKE2B 98f557357877510f6cf279346e9e2e639f644a9c9e1f7929199ae5b03a6df0c51986459ef0d49cf65e87c48bc6d2c20b376edb8484d7ce5ff5849f7305203666 SHA512 261e2764f1cd9920a44660738eed9598c3adb5994341165216e3328fa0cb1d47d12660c0007f3acb726f50334eb7a0384b63346838da149092e6c5f1b3000572
MISC metadata.xml 772 BLAKE2B 4be85c7cd4f0b794fb5af51784d40961156954320046cb773520f6898430cea11ebf367e84ff593ed8c95b23c741ad32b3e9920f06fcd719e05d153981009ba6 SHA512 54e51c201eb124c8ccfc44dba8c47fe77bde86090219e8f38e1aaba9392598eac991bb134a5f98ea585829f9d6d362f237866898f2ef898d6faaeea05354d9af
diff --git a/dev-python/pylatex/pylatex-1.4.1.ebuild b/dev-python/pylatex/pylatex-1.4.1.ebuild
deleted file mode 100644
index 55e919e2046a..000000000000
--- a/dev-python/pylatex/pylatex-1.4.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MY_PN="PyLaTeX"
-MY_P="${MY_PN}-${PV}"
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="A Python library for creating LaTeX files and snippets"
-HOMEPAGE="https://github.com/JelteF/PyLaTeX"
-SRC_URI="https://github.com/JelteF/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples"
-
-RDEPEND="
- dev-python/ordered-set[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-BDEPEND+="
- test? (
- dev-python/quantities[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- app-text/texlive
- dev-texlive/texlive-latexextra
- )"
-
-python_prepare_all() {
- sed -i -e 's:description-file:description_file:' setup.cfg || die # bug 798381
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- if use examples ; then
- dodoc -r examples
- docompress -x /usr/share/doc/"${PF}"/examples
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "compiling generated files" "app-text/texlive dev-texlive/texlive-latexextra dev-texlive/texlive-mathscience"
- optfeature "matplotlib support" dev-python/matplotlib
- optfeature "numpy support" dev-python/numpy
- optfeature "quantities support" dev-python/quantities
-}