summaryrefslogtreecommitdiff
path: root/dev-python/pylatex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-20 09:50:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-20 09:50:23 +0100
commit547caa904733bc2a3ac112415990a114ecbe8824 (patch)
treeb8976d40b28d2cb015e3c07254aee99fe0ad655a /dev-python/pylatex
parent9346d46d1a9e0399ca3a4d3eb40689d0daa58ebc (diff)
gentoo auto-resync : 20:10:2023 - 09:50:23
Diffstat (limited to 'dev-python/pylatex')
-rw-r--r--dev-python/pylatex/Manifest2
-rw-r--r--dev-python/pylatex/pylatex-1.4.2.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/pylatex/Manifest b/dev-python/pylatex/Manifest
index 16ecf15bf0ce..9b32ae03cec8 100644
--- a/dev-python/pylatex/Manifest
+++ b/dev-python/pylatex/Manifest
@@ -1,3 +1,5 @@
+DIST PyLaTeX-1.4.2.gh.tar.gz 307158 BLAKE2B bc20478759fc8315fd7fa2161d1638035c0dad4731c4cb254c78dfc45da2b361b3864d2ec04d6eb8fd7947e9908610eb0104444edff95666abba6a9f6da4cb4b SHA512 dcbe58de0ab715d6fbb571a7ad3981c875eacd08d06244b8715fa240df6f8f072417ae076a5caee204e000bf7eb55097b9ba49eddb5ce666470e494c15aa88ed
DIST pylatex-1.4.1.tar.gz 301482 BLAKE2B c68c8bbf70c5099b3c3146922afe94dcf4f90bfc8644fa165ee27835f4a24642645f9849f2f9fd69656dc07dcc4807869275aacf33a1e5b9c59e539801f8e821 SHA512 55a5734e4d239cef4bcaafa0ba64eea013ba3e86d137de5a5f8311d70c949d783e2e7aad24d39d16a6febbe4bddc34e47248068e1328fe3f95f39a7c7019a3a9
EBUILD pylatex-1.4.1.ebuild 1409 BLAKE2B 3640f58eef86b6dec0f544f3462890eee76cb9a389a707c39e38d83b2729327a4636063325c7924bb5b7e08b180a57d1f97ef5f49b1d79bd18eff0e26b634d3c SHA512 d203089ddbd5f0b9614070759ec95fc21bc35908403b05e323a4a7d4b63a2a16bf4f3aaf0bc665b0b4192c60904c3023bd745892281acf4bee599953b04fef94
+EBUILD pylatex-1.4.2.ebuild 1451 BLAKE2B ff3a14416c7db3256ad95c93b130dd479ef6ac51fd2f97878d032631be19562e783695937c0241f6a3da93c263f824686000fb8e18c322188d4d0ae6b382c48b SHA512 92d1f37f1ef095379613c332db9388fdf5c953a2cd39f6feee66781ee2d9096bbe38a7f3e2a677d06ca8eff463a6b0bb8397fd8bb60fdf33a81639e0787533c8
MISC metadata.xml 772 BLAKE2B 4be85c7cd4f0b794fb5af51784d40961156954320046cb773520f6898430cea11ebf367e84ff593ed8c95b23c741ad32b3e9920f06fcd719e05d153981009ba6 SHA512 54e51c201eb124c8ccfc44dba8c47fe77bde86090219e8f38e1aaba9392598eac991bb134a5f98ea585829f9d6d362f237866898f2ef898d6faaeea05354d9af
diff --git a/dev-python/pylatex/pylatex-1.4.2.ebuild b/dev-python/pylatex/pylatex-1.4.2.ebuild
new file mode 100644
index 000000000000..64beb6cf7322
--- /dev/null
+++ b/dev-python/pylatex/pylatex-1.4.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 optfeature
+
+MY_P="PyLaTeX-${PV}"
+DESCRIPTION="A Python library for creating LaTeX files and snippets"
+HOMEPAGE="
+ https://github.com/JelteF/PyLaTeX/
+ https://pypi.org/project/PyLaTeX/
+"
+SRC_URI="
+ https://github.com/JelteF/PyLaTeX/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/ordered-set[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/quantities[${PYTHON_USEDEP}]
+ app-text/texlive
+ dev-texlive/texlive-latexextra
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # bug 798381
+ sed -i -e 's:description-file:description_file:' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/"${PF}"/examples
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "compiling generated files" "
+ app-text/texlive
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-mathscience
+ "
+ optfeature "matplotlib support" dev-python/matplotlib
+ optfeature "numpy support" dev-python/numpy
+ optfeature "quantities support" dev-python/quantities
+}