summaryrefslogtreecommitdiff
path: root/dev-python/pylast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/pylast
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/pylast')
-rw-r--r--dev-python/pylast/Manifest4
-rw-r--r--dev-python/pylast/metadata.xml4
-rw-r--r--dev-python/pylast/pylast-3.2.1.ebuild36
3 files changed, 40 insertions, 4 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index 83b7ac5d6d80..7328b33eea83 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1,3 +1,5 @@
DIST pylast-1.9.0.tar.gz 42584 BLAKE2B b479fe5b780f6dbd30f20c0e183205ffe87703f26fe8ff04170c7f906705bfe737e965c2a7ebc562943c96a8f9bf7710e84999656d1ff22820254e4f4573f0e2 SHA512 ff3929583d88466738c9a1e964676652717c9f5bd4631f1a0a7855903e77cd394a612b0e2e8fc2f698ac84a34a135f4e940ff7760c2c88bf388ae56fc9c3da65
+DIST pylast-3.2.1.tar.gz 39763 BLAKE2B 1162efb68b89e381528b73eb5fb1dd45a15fcf8129b59fcae824ee78f100f6ea523207cda5b689b2fe66628b0aa5db313b5fa2f504b61b3b4ef6b64ccf13ea5b SHA512 e79a258e6f7c8490d98b4b737abae29cf763dcc5520f47dfe9fe7827f3163bc43ad7dc5c25edd1099cb4c4cd3483cdc5014331caba6f8c3cb29fb1394a8bfa3a
EBUILD pylast-1.9.0.ebuild 601 BLAKE2B cfc5c3b25a62a2ed1842ebd0f0b62047d75b4c9b2b94b1dc2ecbaa6488a89f34f12a6d584b32d6b7dc037daded5acb184f294a563da0a00b7cf5a636c74eba1b SHA512 caca82e19581396e4f666542458c79a42a536ae3d97cb12fbe082fbc57ff96e7a99ac86ae99e4f22f0ad114afa85ee7547ff863854a3930c8679d575cd952fd7
-MISC metadata.xml 894 BLAKE2B 95fd1131de748819af98fcb484c6db7d90d9cf78794dbd9d1d06ebe755020bb09b9ca1d1a232323f4afb409c58a85098fec00994307939ba22fd07fd5de9ea73 SHA512 c5eba42bd263c572e7c73a6df8daa3aad56407d4f26eb1560e1a2fd21fff6a4228522d2c4493481ed7e767e24818cf82b6076ff00937d4214ef25b91986f42a9
+EBUILD pylast-3.2.1.ebuild 862 BLAKE2B 4c07d4609a4030d54b93beb3ec6845846a5405af154813bb09186c739204e7dff02466cb8d5eb7abad51791c781392928bb89b5b57e6e61aacdd9b61a11f1475 SHA512 9ff138e601d565c19a101240a1bc5492c4ef68c56c270532cf521b38bb52f1c8465b48c3af263ddfd361483ac26036f9b59f574bd3581e712b44f583ef025567
+MISC metadata.xml 838 BLAKE2B 6e7565ee2b6821052c09371d7cd6dd33964010c15ef8cb7b7a4a4570628683ed16510385f2a54c084ee605c590132a4bb4926510b9805ac7fd7238bb8d571537 SHA512 e0ed92b884e1a5be485ce44bf08fcb6c38068134e083423bde3e4a2f2180d0cb14f76bf9f154f69247a8008e5a952021925110cf1d0985a7a7d15f082150fad0
diff --git a/dev-python/pylast/metadata.xml b/dev-python/pylast/metadata.xml
index 8f174790787e..8728f1894c38 100644
--- a/dev-python/pylast/metadata.xml
+++ b/dev-python/pylast/metadata.xml
@@ -1,9 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- </maintainer>
+ <!--maintainer-needed-->
<longdescription lang="en">
Python interface to last.fm and other api-compatible websites
diff --git a/dev-python/pylast/pylast-3.2.1.ebuild b/dev-python/pylast/pylast-3.2.1.ebuild
new file mode 100644
index 000000000000..dd510e891907
--- /dev/null
+++ b/dev-python/pylast/pylast-3.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="https://github.com/pylast/pylast"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ test? ( dev-python/flaky[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove setuptools-scm dependency
+ sed -e 's:"setuptools_scm"::' \
+ -e "s:use_scm_version=.*:version='${PV}',:" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "tests failed with ${EPYTHON}"
+}