summaryrefslogtreecommitdiff
path: root/dev-python/pylast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-python/pylast
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-python/pylast')
-rw-r--r--dev-python/pylast/Manifest2
-rw-r--r--dev-python/pylast/pylast-4.2.1.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index 2ce055bd6fc0..fa0c20944425 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1,3 +1,5 @@
DIST pylast-4.2.0.tar.gz 39761 BLAKE2B 35ab18928b2761255a25e2b8549fe852f28f04057c9fb1075fa223333d079c07340ea17d425695d17c0ec99d67e6e31ed93f6fe60df1121ae7c298cca99b1b03 SHA512 9c8c0eea0d3f54514ba06ad7da0868844f8dc53715717decb3b56772093e637673deb22ee4277e508d7e659b48c79733514c67c9af0283e8aa0032caeae3d44f
+DIST pylast-4.2.1.tar.gz 39787 BLAKE2B 1f2f06671ce38bd42f7297279a58f674c3af8f66de4fe804d90e3fc178c73f09a24f65bbc4fd534da0c04f593dc5eb31f03da38a4ca969ea31a04978a603b7b4 SHA512 c1418ff1e6b6ab905d790cc83eb1a4b3172c0c28d523c2bbd641523a2e2601a84aff126dafd047f0fb9b82744bca883648e197b273026611f47671d39afd4fc6
EBUILD pylast-4.2.0.ebuild 710 BLAKE2B f8aee8425b2f57dc04d7b7848f5d8f5ea3fdd7b8ad5ee77ff62f36173e1e364f66fd796350594bef99bc04aa80881e217038fe3e9cceba1d288038cd51ba42f4 SHA512 70af9cd05bce1b889dacf7ca839f8079dfe65821421896d27cfd199312fb1c55e733f45379801347347c95939c0998fd8513bfe2af2bf5ec8be895f083611a3d
+EBUILD pylast-4.2.1.ebuild 695 BLAKE2B c6dcdf021a55134b9f4acd7871a86f556afa3937caa438216ec058b032aed31efa7957b9344fdfe7d2c28e48b2e215ea5d410b86c915c9f6ff81f12dbfe211b7 SHA512 a93ba6d7f6225c5d31de2c82453f381913e3960e6a2d2b3d48f6c76bbca4deb74f0eec6d96c7e62351c1a6f62c18798f05ddb184ffdfd4423e007b5a5afeafd1
MISC metadata.xml 906 BLAKE2B 6bfe370296de02da86dbc7d9b193ba499a3667cd3720014bdea0c37e51b0c945564e9bf5f2b6ef65008dbc58ff7b7799e5464b292ca1d3588898849123fe8ff8 SHA512 15294c8d03e6f8a9571f2610bd8ed831e0c274a124e4533f7375b0a753e95d2277503ab38541c1dedc1e810fd87a2bc154424e39b52135b07f06f788165f8619
diff --git a/dev-python/pylast/pylast-4.2.1.ebuild b/dev-python/pylast/pylast-4.2.1.ebuild
new file mode 100644
index 000000000000..15fc748bcb74
--- /dev/null
+++ b/dev-python/pylast/pylast-4.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="https://github.com/pylast/pylast"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/flaky[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests --install pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}