summaryrefslogtreecommitdiff
path: root/dev-python/pylast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 03:54:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 03:54:55 +0100
commit2ecd7994be1409f2a65bfca700904d2a78fd7bbe (patch)
tree0248ea4d4f411ea88c27470c15ebc725bb04baa1 /dev-python/pylast
parentc22e93ab35a8cb604c41623a7b2cda059c462b70 (diff)
gentoo auto-resync : 26:10:2022 - 03:54:55
Diffstat (limited to 'dev-python/pylast')
-rw-r--r--dev-python/pylast/Manifest2
-rw-r--r--dev-python/pylast/pylast-5.1.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index a86a5ff8f5a1..14c3df9fe142 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1,3 +1,5 @@
DIST pylast-5.0.0.tar.gz 39868 BLAKE2B 0cb6d96ac74a2e62325b8a91cc3601ab4ea7ea629ef40c02ce1afe13fd067abc48f24092138fc4584382c9c7f8c62eb070f1a3173b39768ac4ff8e3904c255d2 SHA512 ebad77e66d39b5625d0afae3bba346769159f39dfbbca0fea6aa0e6ad683fea6ea04093dd4738e378ac419edcc9970e8070d7ff912cc08110a5f41f7993489ce
+DIST pylast-5.1.0.gh.tar.gz 40178 BLAKE2B f290afa72d71cb2f88793aaa31aa059a603375e91b310c3ca9180ed5626c589f3d91ae1961db15e256b01bd019b8e59dd48be45ff96683707c05ee9170dfed84 SHA512 64c71f5365638f3bdb435ac2d7405bd1e7a3ebe95fee97469c64bee63ad9850d45781756ebd59942c70780830fbb0519874908d2894e227acadedb5120c3b9ab
EBUILD pylast-5.0.0.ebuild 773 BLAKE2B 4689bd56b0a492bbe89a755d170fd26ac093eba8e6188e82ccea5beee9ce01826c1805700d5a1d621d920efb31195c1b0d6ec437a32669da33be7cb736078012 SHA512 289710ed082564ca66a389bb2ecd226172a94b1431e4fd9209759fb58ca2c1032087d45aa1340e975c138254599de524dcf979a714e0a0288a7ae38558f91dfe
+EBUILD pylast-5.1.0.ebuild 776 BLAKE2B ecf5ebd5763f00837b3158438c556ba68f2dcc381347d2c821f72177d77d801a962fc91f4a67ff87be551cf0159a08c5a30cb2501802f86257efad4d8ceb7f0d SHA512 ecfe86f13d7b0ab5902f570d0e3d3f981b8fcb7cf084e6dea4a00e5a04ee91531f8c840f2023910cb70f5ba6c64ffac42dfed1723954d7961441cd4c4d0c9e6b
MISC metadata.xml 907 BLAKE2B a4a6aee5b2e805d27d001b7c51dfb2a26b935c38380e85027059b02e75057fc02f9ad311fd21326f6f16e7528a15c0577aae31f695f8a74ac42d274c10e7ca17 SHA512 1d0b7327a4e9a24940cff7a27b64bf5a27d5e2a1391d31a99d3473fccd54e534722ba826a64bcfc5f0da7a505241e617d23aa1f7490218f1d39af4cd3aa29357
diff --git a/dev-python/pylast/pylast-5.1.0.ebuild b/dev-python/pylast/pylast-5.1.0.ebuild
new file mode 100644
index 000000000000..07ac0a967207
--- /dev/null
+++ b/dev-python/pylast/pylast-5.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="
+ https://pypi.org/project/pylast/
+ https://github.com/pylast/pylast/
+"
+SRC_URI="
+ https://github.com/pylast/pylast/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}