summaryrefslogtreecommitdiff
path: root/dev-python/pylast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-python/pylast
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-python/pylast')
-rw-r--r--dev-python/pylast/Manifest4
-rw-r--r--dev-python/pylast/pylast-4.0.0.ebuild4
-rw-r--r--dev-python/pylast/pylast-4.1.0.ebuild33
3 files changed, 38 insertions, 3 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index 9200f877ce40..ca55e9502f1a 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1,3 +1,5 @@
DIST pylast-4.0.0.tar.gz 40044 BLAKE2B 89402027494d608bffc4738857d8a7728175cf29a68af259aec1d6ab3755c5e02268bbacac2ff9bd8d8c6490b86ae200aeed59f34c764a4c2f90ea59cb732070 SHA512 093845c718269ed5a0b5223182e60192a71e2fed9270fec453b96b0b2a5488a0c5a8f6386edb42ed183b97cb7ea00397b4491ff72cbf72f9e7d42dc90fae66e7
-EBUILD pylast-4.0.0.ebuild 802 BLAKE2B 097c6a3bbcb5c6c8dffa96d4c5aa96e097643ca8e7676e792988ab3ffecc84880812a7a7458c5d7a426b88cf1b527be56369815a658ef53e42ad6f5ac24b41ac SHA512 b03fab1b424b07d4b8411c029e9ca121b42564679000c866d42885ddb720c228f387435f7feab3bd4f241fc3d8b0a50e4bad048540ea510d2deebeb6735240bb
+DIST pylast-4.1.0.tar.gz 39592 BLAKE2B ff1f9f025701ebf741e53d96c2ba0c34d7a165d1c248973874484ed0c2e5e24693631f31de516fb4a58ea14014cb38c60fe04b9d116128a6a259346f16085dc2 SHA512 90be1cafb9252c2c19db9b179350269dc8eec82545487394d671d411e4fc2ca10fcd85259874f72c39674474c75274446cd8c64cd5f2274ef98ebf5ba7fbb351
+EBUILD pylast-4.0.0.ebuild 801 BLAKE2B 04cea42e91abf06a96619eee755317b1c48fbe35b62cbc2ac2a772ad7df8d1673310a4368f315583d41148fbc1e3a656c10c24e1a5946d97f1bde1b5c997e3d4 SHA512 ac00fabd136b3245db9b447fb6ba487d3d52c9f3be155817a27b900c735f26f8f9f18de4bc2205a5185920c90bbf0604debbc0746576f837871d9e4db05c983e
+EBUILD pylast-4.1.0.ebuild 806 BLAKE2B 7a4136a02361ab2399bf062f4034bb3ec03d2dd43fb2caa4f6e3bf49c0c07ff71d6855f0c3d74dabc7a373fee59bf4c0dba890905ed6e0e21b7523d4cfb38c84 SHA512 4cfc6a9b426c87e48cfe2ad518b6852d995a6cbdb81f1d6f7d3f9eb1ed45f80ab9fdef62b2962bc4cf50e50cc67915d101f86dcd2f0f1c34230223050fd595f2
MISC metadata.xml 906 BLAKE2B 6bfe370296de02da86dbc7d9b193ba499a3667cd3720014bdea0c37e51b0c945564e9bf5f2b6ef65008dbc58ff7b7799e5464b292ca1d3588898849123fe8ff8 SHA512 15294c8d03e6f8a9571f2610bd8ed831e0c274a124e4533f7375b0a753e95d2277503ab38541c1dedc1e810fd87a2bc154424e39b52135b07f06f788165f8619
diff --git a/dev-python/pylast/pylast-4.0.0.ebuild b/dev-python/pylast/pylast-4.0.0.ebuild
index 1e4b885f9d02..972dee5a006e 100644
--- a/dev-python/pylast/pylast-4.0.0.ebuild
+++ b/dev-python/pylast/pylast-4.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="amd64 arm ~hppa ~ia64 ~ppc ~ppc64 sparc x86"
+KEYWORDS="amd64 arm ~hppa ~ia64 ~ppc ppc64 sparc x86"
RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
BDEPEND="
diff --git a/dev-python/pylast/pylast-4.1.0.ebuild b/dev-python/pylast/pylast-4.1.0.ebuild
new file mode 100644
index 000000000000..bdb88af44809
--- /dev/null
+++ b/dev-python/pylast/pylast-4.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="https://github.com/pylast/pylast"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/flaky[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "tests failed with ${EPYTHON}"
+}