summaryrefslogtreecommitdiff
path: root/dev-python/pylama
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-09 02:15:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-09 02:15:09 +0100
commit3fd9d065ab109700e92fc1cea2a6519a39a5b007 (patch)
tree2666118c9404e846180636fbd2de92e3bd7870fd /dev-python/pylama
parent11c791ab62dc711840a52676eef212362840fc17 (diff)
gentoo auto-resync : 09:08:2022 - 02:15:09
Diffstat (limited to 'dev-python/pylama')
-rw-r--r--dev-python/pylama/Manifest2
-rw-r--r--dev-python/pylama/pylama-8.4.1.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pylama/Manifest b/dev-python/pylama/Manifest
index 613c6db696ac..aa0f7063c364 100644
--- a/dev-python/pylama/Manifest
+++ b/dev-python/pylama/Manifest
@@ -1,3 +1,5 @@
DIST pylama-8.3.8.tar.gz 36319 BLAKE2B 5251bd32549793a8d06b6180a3e4f4c20f23dbdfecc146eb877222995bcadcf8cf8343f99ad897fb3e00c0f455762f82f4e3d157c34be6f21b4f220e87b636a2 SHA512 b55d7cb28a94f19270bde7ff6a8d760ef9132c845aaa85340271e42af6987fcc919ba9b0ddaebb6da6c1ffe789aaf39c83d273f8adea88db58a9218577899924
+DIST pylama-8.4.1.gh.tar.gz 37850 BLAKE2B dea99fc784736f3b229c5d82a59f2e2b5490fbe344ad98167e30e550b6c774c7b42cbddfedeb073d9d843cf53169c441812974036b06088ab07d7b7996def4a5 SHA512 fb038c39a2e962bd065ac5ef545f1be50f5b230141141a55e1701ffdc6a241b5778613ac91f29ff648b7ce48fa969c3961a11b7e906b6e350c84b57eea5369cd
EBUILD pylama-8.3.8.ebuild 1006 BLAKE2B 3e2a3eada1fd7a44bdfcc1ea51c736922f3162ce5dffa00d11ff3dea366bd27b7f589de3e681618298c24ee31db7977ea2e8e9add35748790ce1104076eb7376 SHA512 2067b81d72b61bf61db5edf3c4a90615fb4d8b90a630f48a99f9fcc4b0a7bda3282f64dec22e3e854d7d1f943d20a0d7051e851413b151a47814bae1842e7d5d
+EBUILD pylama-8.4.1.ebuild 1017 BLAKE2B ba71f62e2961f3ca6920db633813bd76741f8ccf4aad5be1a4eb34b60f74cc7e91c5c820f470ec4427d3feb6cc9ad762ef52f80333dfdf904d4bc43e63170f33 SHA512 5c2270aa803e16bc0be05cd3c5093b211a0c87455b31d26e4b8aa6e0ef001f32e3321c7ac44623657f13bd02b679d9dc7ecaa30d0a7f08cb13fb1cdfc27030b8
MISC metadata.xml 490 BLAKE2B 4c0dda4b057901937d4b6af02041edc0544e392ade5a3497de0d58ba5c1423332e6c1f0b289a3bbbdcccc1b45eedc01f158778e99f9a6f3911cb6b91d999519d SHA512 d3dc1fdaee046554de697e6aeb324910199ea9329a57ac89cebc96f2143e4d2482e31cadc5df16893fcd012058282f600fef676992d8dd55dba3f045f69bc52b
diff --git a/dev-python/pylama/pylama-8.4.1.ebuild b/dev-python/pylama/pylama-8.4.1.ebuild
new file mode 100644
index 000000000000..45e31850131b
--- /dev/null
+++ b/dev-python/pylama/pylama-8.4.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Code audit tool for python"
+HOMEPAGE="https://github.com/klen/pylama"
+SRC_URI="https://github.com/klen/pylama/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-6.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/eradicate[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+ dev-python/radon[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # not packaged
+ tests/test_linters.py::test_quotes
+ tests/test_linters.py::test_vulture
+)