summaryrefslogtreecommitdiff
path: root/dev-python/pyjwt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-19 13:04:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-19 13:04:34 +0100
commit63b2c0efb0684f8577c44d181c991cf471351fc5 (patch)
treeb8f55ee32396b20b2788beff92c3ce55c4e9c14f /dev-python/pyjwt
parent5c9d85c89af4d9d7228124d3d0bcdd14a9aba91a (diff)
gentoo auto-resync : 19:07:2023 - 13:04:34
Diffstat (limited to 'dev-python/pyjwt')
-rw-r--r--dev-python/pyjwt/Manifest2
-rw-r--r--dev-python/pyjwt/pyjwt-2.8.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pyjwt/Manifest b/dev-python/pyjwt/Manifest
index 1148047620c7..8ed4a692d7ed 100644
--- a/dev-python/pyjwt/Manifest
+++ b/dev-python/pyjwt/Manifest
@@ -1,3 +1,5 @@
DIST PyJWT-2.7.0.tar.gz 77902 BLAKE2B ff1e1c5dfd301a86a42eb6b4b2d6d900b15acdf60875bac49aee980b75b724292ff48b169cd2b9708388860ea93fd94f3cbf891f4606bfeb544e07a14c328bb8 SHA512 0aa886dfdc3c668b45e1c649cc3fbe3c2dec7476f46bd361ff74f6e9c7ea0ad40306a8a8ae84bfd63fe1c1364302b8aa69943013c951b32c9f24e4782b94ca8d
+DIST PyJWT-2.8.0.tar.gz 78313 BLAKE2B b5031ec0ea672ef2dffc077aba6c781a20a7497257a16241841c0e0158017370581e3c9785d930772290c25fc9029e71a5d8744d999b135b29715a4f35720508 SHA512 74e74cf8c78494a9e51a2a186347361388031d5c0d0864df2a5d051621d9d31dff617ab1d7ebb4a829cc7d409d196e1bdb3b361ec888b6c14f1abea77544475e
EBUILD pyjwt-2.7.0.ebuild 709 BLAKE2B 17b76d60c992206b367bc592a0fa01fc7142b9681c1c5a6055b7f8e565e1d1114716aca989fba9b319a207971f8bc83ee07e95823e72e3ff377b74bf9f053514 SHA512 656e5f8fc0c5f6f9dd1b5829a5a31928177a3a7c97dd8b5f5ae9c02f9df1ea6bc07543aa3d25a6e253a3390763a693b65b6038a7a3e108ae6715acdaf59621af
+EBUILD pyjwt-2.8.0.ebuild 830 BLAKE2B 5da766d408a3d6bf097fb8aa89a135f570f53fceaa63c0d226612979b2c0525770cde937a9c8d5e7fa089ff346057e231d0a4517a74110a4da088f0e6ed12069 SHA512 85756fcf2dbd5840a5584533be44ecf3ac854d47d1d975dbbf848538dc84e26d2a3002bf0f74790dd31f1772797940c3df107fd72e946a3b6121158b9235bf51
MISC metadata.xml 450 BLAKE2B e0a5244140aed7eb1dbc7d1bedf41b64f999ada11a82d5a7c3720501d824c789590e5339d5855fa4d0f96ff1b572e86af41859f8f14105f2f9b1a715d9d71d87 SHA512 83bce7997e724867cf1962ce75d8bb8e7a4e7a8dcdb42b95d9d323ca3a3ea4584020d4b700885e1afcb753d4fcacee23ec7b25066e93c0ac5eb614f65d140f29
diff --git a/dev-python/pyjwt/pyjwt-2.8.0.ebuild b/dev-python/pyjwt/pyjwt-2.8.0.ebuild
new file mode 100644
index 000000000000..612aa0783eac
--- /dev/null
+++ b/dev-python/pyjwt/pyjwt-2.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="PyJWT"
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="JSON Web Token implementation in Python"
+HOMEPAGE="
+ https://github.com/jpadilla/pyjwt/
+ https://pypi.org/project/PyJWT/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ !dev-python/python-jwt
+"
+BDEPEND="
+ test? (
+ >=dev-python/cryptography-3.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_jwks_client.py::TestPyJWKClient::test_get_jwt_set_sslcontext_default
+)
+
+pkg_postinst() {
+ optfeature "cryptography" dev-python/cryptography
+}