summaryrefslogtreecommitdiff
path: root/dev-python/pyjwt/pyjwt-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-python/pyjwt/pyjwt-2.0.0.ebuild
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-python/pyjwt/pyjwt-2.0.0.ebuild')
-rw-r--r--dev-python/pyjwt/pyjwt-2.0.0.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/pyjwt/pyjwt-2.0.0.ebuild b/dev-python/pyjwt/pyjwt-2.0.0.ebuild
deleted file mode 100644
index b74a2aeeafea..000000000000
--- a/dev-python/pyjwt/pyjwt-2.0.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-
-inherit distutils-r1 optfeature
-
-MY_PN="PyJWT"
-DESCRIPTION="JSON Web Token implementation in Python"
-HOMEPAGE="https://github.com/jpadilla/pyjwt/ https://pypi.org/project/PyJWT/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}"/${MY_PN}-${PV}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND=""
-DEPEND="
- test? (
- >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- find . -name '__pycache__' -prune -exec rm -rf {} + || die
- find . -name '*.pyc' -delete || die
-
- # enables coverage, we don't need that
- rm setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-pkg_postinst() {
- elog "Available optional features:"
- optfeature "cryptography" dev-python/cryptography
-}