summaryrefslogtreecommitdiff
path: root/dev-python/pyjwt/pyjwt-1.5.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
commit520a5b56dff7c24c9d42eafec142cb78b44f8e3e (patch)
treef562f705600dbd2292e97c0b4145787c2a8d1f97 /dev-python/pyjwt/pyjwt-1.5.3.ebuild
parent3811bc3072bf19e2be351d2c63f81532945c0f21 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'dev-python/pyjwt/pyjwt-1.5.3.ebuild')
-rw-r--r--dev-python/pyjwt/pyjwt-1.5.3.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-python/pyjwt/pyjwt-1.5.3.ebuild b/dev-python/pyjwt/pyjwt-1.5.3.ebuild
index ae1f2157dead..4f508b7efe49 100644
--- a/dev-python/pyjwt/pyjwt-1.5.3.ebuild
+++ b/dev-python/pyjwt/pyjwt-1.5.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} pypy )
inherit distutils-r1 eutils
@@ -24,8 +24,6 @@ DEPEND="
test? (
>=dev-python/cryptography-1.4.0[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
)"
S="${WORKDIR}"/${MY_PN}-${PV}
@@ -34,11 +32,14 @@ python_prepare_all() {
find . -name '__pycache__' -prune -exec rm -rf {} \; || die "Cleaning __pycache__ failed"
find . -name '*.pyc' -exec rm -f {} \; || die "Cleaing *.pyc failed"
+ # enables coverage, we don't need that
+ rm setup.cfg || die
+
distutils-r1_python_prepare_all
}
python_test() {
- esetup.py test
+ pytest -vv || die "Tests fail with ${EPYTHON}"
}
pkg_postinst() {