summaryrefslogtreecommitdiff
path: root/dev-python/pyjsparser/pyjsparser-2.7.1_p20190421.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/pyjsparser/pyjsparser-2.7.1_p20190421.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/pyjsparser/pyjsparser-2.7.1_p20190421.ebuild')
-rw-r--r--dev-python/pyjsparser/pyjsparser-2.7.1_p20190421.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyjsparser/pyjsparser-2.7.1_p20190421.ebuild b/dev-python/pyjsparser/pyjsparser-2.7.1_p20190421.ebuild
new file mode 100644
index 000000000000..d0d1cdfd469d
--- /dev/null
+++ b/dev-python/pyjsparser/pyjsparser-2.7.1_p20190421.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_COMMIT="5465d037b30e334cb0997f2315ec1e451b8ad4c1"
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast javascript parser based on esprima.js"
+HOMEPAGE="
+ https://github.com/PiotrDabkowski/pyjsparser/
+ https://pypi.org/project/pyjsparser/
+"
+SRC_URI="https://github.com/PiotrDabkowski/${PN}/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+RESTRICT="!test? ( test )"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ test? (
+ dev-python/js2py
+ dev-python/pytest
+ )
+"
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+python_test() {
+ "${EPYTHON}" ./test_runner.py || die "tests failed with ${EPYTHON}"
+}