summaryrefslogtreecommitdiff
path: root/dev-python/pyinsane
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyinsane
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyinsane')
-rw-r--r--dev-python/pyinsane/Manifest5
-rw-r--r--dev-python/pyinsane/metadata.xml21
-rw-r--r--dev-python/pyinsane/pyinsane-2.0.10.ebuild30
-rw-r--r--dev-python/pyinsane/pyinsane-2.0.12-r1.ebuild33
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/pyinsane/Manifest b/dev-python/pyinsane/Manifest
new file mode 100644
index 000000000000..65dca05d7135
--- /dev/null
+++ b/dev-python/pyinsane/Manifest
@@ -0,0 +1,5 @@
+DIST pyinsane-2.0.10.tar.gz 327159 BLAKE2B ae63e08fc557513ccac0633fac47bb29b3c8a023c481289ec60724f5fcdae0827e02d5f37d3f104d454ebcb1d1a7681248866461bce6201f056c988f858aa0d3 SHA512 bb882ab51c1e6cea7cad75851ffe5918ee08467d4772d27c23a0c5ec9f2dea3ee7d83601ae35e56e2f717ff7683cec5a45aa47b2a4e167fe4dddb9db3229a3b1
+DIST pyinsane2-2.0.12.tar.gz 56107 BLAKE2B 81085e414f162c4fe3623e05b904c35864b95c8ceb5aa25cb92aa87086d4ee44f9f1bea58239373217e93793bfba0d8bb894ab75d69d6c213741cf6e53721284 SHA512 72fc87d5c7eab078f4a9694569c5759046587a8439820fadfe1b8899b7445e063f9fc2f3e93a86b1f9329f729466a5e19b86e46c128caf9ac8b143cfd9e17817
+EBUILD pyinsane-2.0.10.ebuild 851 BLAKE2B 2ec7f8ce75cc7cdece605e1f3dd68dba4e445f4958da926c1f5659d6381db94262f8020c3ab8c9c8d48035a120eb2a82ac59ede1d9f761d4dcbd4c3cf232f4b7 SHA512 14f5240f6080be599afe2cc902f4ee133adeb21292978024f132af70cffe69a069fff6527db1f4fc4fe5204425906e708f51f131dec38de74ad8a3d36ac9e649
+EBUILD pyinsane-2.0.12-r1.ebuild 804 BLAKE2B 6145e68a8b44d0770819b57a0e560193ac5c9b4d4924b83e4bf186d920f95aa5df26bdbb01cf152d43af7707e454e0b09ab31c9f85be3147fceb7f992e98881d SHA512 dfea1a0425b758da888a7949db79b646246104aabe1c4e94369a517dd0fe1b8c36a8fc30e9aa5372ab581c878e5d13809682284d2831e7d30599164b9b1fc46e
+MISC metadata.xml 970 BLAKE2B 66f9e22270e1f6bb94091085d49b6ee20aae2cc8c32e8e89b8325190b21932ce2431545b7bc72384ea2f82d9c71577d5ce08434dd2c9b237de9c7056307fc99a SHA512 1b5b839ca3e96ea99a6239cf6d5989710484b595405a3ce06192587984a0a5552bfbf0df770a3b986e078f4bbd27338d378f775cc0afdfa5bc4dc17190bf1e87
diff --git a/dev-python/pyinsane/metadata.xml b/dev-python/pyinsane/metadata.xml
new file mode 100644
index 000000000000..81b6fe8da176
--- /dev/null
+++ b/dev-python/pyinsane/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <longdescription lang="en">
+Python implementation of the Sane API (using ctypes) and abstration layer.
+
+The code is divided in 3 layers:
+
+ * rawapi : Ctypes binding to the raw Sane API
+ * abstract : An Object-Oriented layer that simplifies the use of the Sane API and try to avoid possible misuse of the Sane API. When scanning, it also takes care of returning a Pillow image.
+ * abstract_th : The Sane API is not thread-safe and cannot be used in a multi-threaded environment easily. This layer solves this problem by using a fully dedicated thread.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">pyinsane2</remote-id>
+ <remote-id type="github">openpaperwork/pyinsane</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyinsane/pyinsane-2.0.10.ebuild b/dev-python/pyinsane/pyinsane-2.0.10.ebuild
new file mode 100644
index 000000000000..5eb8db203937
--- /dev/null
+++ b/dev-python/pyinsane/pyinsane-2.0.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Sane API and abstration layer"
+HOMEPAGE="https://github.com/openpaperwork/pyinsane"
+SRC_URI="https://github.com/openpaperwork/pyinsane/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="media-gfx/sane-backends
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # Tests require at least one scanner with a flatbed and an ADF
+
+python_prepare_all() {
+ sed -e "/'nose>=1.0'/d" \
+ -e "s/find_packages()/find_packages(exclude=['examples','tests'])/" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/pyinsane/pyinsane-2.0.12-r1.ebuild b/dev-python/pyinsane/pyinsane-2.0.12-r1.ebuild
new file mode 100644
index 000000000000..c1235e64b984
--- /dev/null
+++ b/dev-python/pyinsane/pyinsane-2.0.12-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+MY_PN="${PN}2"
+
+DESCRIPTION="Python implementation of the Sane API and abstration layer"
+HOMEPAGE="https://github.com/openpaperwork/pyinsane"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="media-gfx/sane-backends
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # Tests require at least one scanner with a flatbed and an ADF
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+python_prepare_all() {
+ sed -e "/'nose>=1.0'/d" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}