summaryrefslogtreecommitdiff
path: root/dev-python/pyinotify/pyinotify-0.9.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/pyinotify/pyinotify-0.9.6.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/pyinotify/pyinotify-0.9.6.ebuild')
-rw-r--r--dev-python/pyinotify/pyinotify-0.9.6.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/pyinotify/pyinotify-0.9.6.ebuild b/dev-python/pyinotify/pyinotify-0.9.6.ebuild
index 765b6630ae65..5221c9f20f1f 100644
--- a/dev-python/pyinotify/pyinotify-0.9.6.ebuild
+++ b/dev-python/pyinotify/pyinotify-0.9.6.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7}} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6..9}} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
DESCRIPTION="Python module used for monitoring filesystems events"
-HOMEPAGE="http://trac.dbzteam.org/pyinotify https://pypi.org/project/pyinotify/"
+HOMEPAGE="
+ http://trac.dbzteam.org/pyinotify
+ https://pypi.org/project/pyinotify/
+ https://github.com/seb-m/pyinotify/"
SRC_URI="http://seb.dbzteam.org/pub/pyinotify/releases/${P}.tar.gz"
LICENSE="MIT"
@@ -17,9 +20,6 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="examples"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
python_install_all() {
if use examples; then
dodoc -r python3/examples