summaryrefslogtreecommitdiff
path: root/dev-python/pyinotify/pyinotify-0.9.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pyinotify/pyinotify-0.9.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pyinotify/pyinotify-0.9.6.ebuild')
-rw-r--r--dev-python/pyinotify/pyinotify-0.9.6.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pyinotify/pyinotify-0.9.6.ebuild b/dev-python/pyinotify/pyinotify-0.9.6.ebuild
new file mode 100644
index 000000000000..6579604fd3aa
--- /dev/null
+++ b/dev-python/pyinotify/pyinotify-0.9.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python module used for monitoring filesystems events"
+HOMEPAGE="http://trac.dbzteam.org/pyinotify https://pypi.python.org/pypi/pyinotify"
+SRC_URI="http://seb.dbzteam.org/pub/pyinotify/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_install_all() {
+ use examples && local EXAMPLES=( python2/examples/. )
+ EXAMPLES+=( python3/examples/. )
+ distutils-r1_python_install_all
+}