summaryrefslogtreecommitdiff
path: root/dev-python/pyilmbase
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/pyilmbase
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/pyilmbase')
-rw-r--r--dev-python/pyilmbase/Manifest2
-rw-r--r--dev-python/pyilmbase/pyilmbase-2.5.6.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pyilmbase/Manifest b/dev-python/pyilmbase/Manifest
index 8390964bf16d..02fa4479f901 100644
--- a/dev-python/pyilmbase/Manifest
+++ b/dev-python/pyilmbase/Manifest
@@ -1,4 +1,6 @@
AUX pyilmbase-2.5.2-0001-Fix-pkgconfig-file-for-PyIlmBase-to-include-prefixes.patch 1192 BLAKE2B 7590379873fd2be694a70d272a082fe6916e596f3b0945bc5f6c390880cc31e6b07da9bcedeb4e9bb048cd50f87ccff5b61857903f0e295af37dc005e4792a7e SHA512 7ef4a769086e5cf62cd3ad18bb169578da5557bb7006250f7dc13e6b623e46e2805ec9b51926f0eba27fb414eecf2f0017dc282f67ee639edf013ff135c54086
DIST pyilmbase-2.5.5.tar.gz 27536865 BLAKE2B d0c0b2fd39b2cfafb60b6d0de3960063ff62341cf22be519f874c0c83f05cb604c5d503bb8b88514c71c5a54a79afa80a7fd00c2df15ec2193f6b3cffdc117c6 SHA512 e511af26a8fe2175a641fd25d2dcc6ef807e00bee2aff06a4784125f916ffd47fe376fe0621d385b604180a239bbfee063f8ceee3f7b731fde3c38558e9fdcdf
+DIST pyilmbase-2.5.6.tar.gz 27540385 BLAKE2B eea64c6ae4500de31673f3127da6ac98272e85a2c93e2aed96494cc24c397edbce508f0721387be5bbabc4dde596dccf61212709173b7cebd4212dbfbd1e4b65 SHA512 8d4582a5f2adcd5eb1486cabe033f9ecaa0292000bf7fa484a94e1d9ec908678a5a903fc6a1beba22bcd9c7f06ac51236834f448ea8aaf4462a338de886f0412
EBUILD pyilmbase-2.5.5.ebuild 1528 BLAKE2B 53c15d9d6f57246d04bc1ce5e846973fcbdaef51af9f2fd1610c2a4e8a993b01459650d4c732c3f83b585ae654c2d41ffc33e1412cc048047ac5e887dae14ac3 SHA512 9f956a1b3e8224ab95e6e364b8b8f80eb4b68a52f4c3b5b9dea85cff7320a9f9dcb66170ce45dea5ae1bf48dadbd1592430fdbc8b2b9a897aa1c328adf286698
+EBUILD pyilmbase-2.5.6.ebuild 1530 BLAKE2B 2d3dd8edc3b264abb8980320c2e785b3e2ffda1eaf1342ef226bc8a43856780fd557ea8729361594df31a624641ca2a9a12cdd75d74a9d8e50f5b04a5b4992d8 SHA512 8ef19f6c05652f73d734cdf6d04dbedb90a0e6e202a118b4e867ee35fc7d01f994c2abb3a6c3555b7cd25da11a6f0a17b4fad6f6c13a6c578c9cd7e03435ade2
MISC metadata.xml 690 BLAKE2B 857ad16bdb3ab2ac35ca5d8e41a5e2302aa7e130c0dac5125135ba92569959b91278cfb3da987e4647aba4dab3898d7de9c6e340e20551379592a1c90d236882 SHA512 357ac1026fdacfdac7ced27c40fcf936a14dac7a044e8b168de7ac126811df67fb9e9ba01f8ee0fcf40ef86906abf37880fba6a782f27f832ca889de04ea4e58
diff --git a/dev-python/pyilmbase/pyilmbase-2.5.6.ebuild b/dev-python/pyilmbase/pyilmbase-2.5.6.ebuild
new file mode 100644
index 000000000000..76a74d8d9078
--- /dev/null
+++ b/dev-python/pyilmbase/pyilmbase-2.5.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit cmake python-single-r1
+
+DESCRIPTION="IlmBase Python bindings"
+HOMEPAGE="https://www.openexr.com"
+SRC_URI="https://github.com/AcademySoftwareFoundation/openexr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/openexr-${PV}/PyIlmBase"
+
+LICENSE="BSD"
+SLOT="0/25"
+KEYWORDS="amd64 ~x86"
+IUSE="exceptions +numpy test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ ~media-libs/ilmbase-${PV}:=
+ sys-libs/zlib
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.62.0-r1:=[python,${PYTHON_MULTI_USEDEP}]
+ numpy? ( >=dev-python/numpy-1.10.4[${PYTHON_MULTI_USEDEP}] )
+ ')
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-admin/chrpath
+ virtual/pkgconfig
+"
+
+#PATCHES=(
+# "${FILESDIR}"/${PN}-2.5.2-0001-Fix-pkgconfig-file-for-PyIlmBase-to-include-prefixes.patch
+#)
+
+DOCS=( README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Python2=ON
+ -DPYILMBASE_INSTALL_PKG_CONFIG=ON
+ -DPYIMATH_ENABLE_EXCEPTIONS=$(usex exceptions)
+ -DPython3_EXECUTABLE="${PYTHON}"
+ -DPython3_INCLUDE_DIR=$(python_get_includedir)
+ -DPython3_LIBRARY=$(python_get_library_path)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ if use numpy; then
+ python_domodule "${BUILD_DIR}/${EPYTHON/./_}/imathnumpy.so"
+ chmod +x "${D}/$(python_get_sitedir)/imathnumpy.so" || die
+ chrpath -d "${D}/$(python_get_sitedir)/imathnumpy.so" || die
+ fi
+}