summaryrefslogtreecommitdiff
path: root/dev-python/pyilmbase
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /dev-python/pyilmbase
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'dev-python/pyilmbase')
-rw-r--r--dev-python/pyilmbase/Manifest2
-rw-r--r--dev-python/pyilmbase/pyilmbase-2.5.3.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/pyilmbase/Manifest b/dev-python/pyilmbase/Manifest
index b1c095dd827d..ccf173c0dbd9 100644
--- a/dev-python/pyilmbase/Manifest
+++ b/dev-python/pyilmbase/Manifest
@@ -1,4 +1,6 @@
AUX pyilmbase-2.5.2-0001-Fix-pkgconfig-file-for-PyIlmBase-to-include-prefixes.patch 1192 BLAKE2B 7590379873fd2be694a70d272a082fe6916e596f3b0945bc5f6c390880cc31e6b07da9bcedeb4e9bb048cd50f87ccff5b61857903f0e295af37dc005e4792a7e SHA512 7ef4a769086e5cf62cd3ad18bb169578da5557bb7006250f7dc13e6b623e46e2805ec9b51926f0eba27fb414eecf2f0017dc282f67ee639edf013ff135c54086
DIST pyilmbase-2.5.2.tar.gz 27525326 BLAKE2B c48a61513457f2c04f3a512963ae27eaf154933ffe7c6ff3e2d71f27f246ae624a34dbe6f8ab500c51a56898ad0f61e6784f5cd3f9c3df591ce347b46ba4ac88 SHA512 62f98695cf56600303db9c2d13d34cacc1851a103d8ffb7e7ce8c6d9d14e6bf02804836c718ae03e8d685ef3dda0cf7b2130e2d363f8095b22a15bf30d706fab
+DIST pyilmbase-2.5.3.tar.gz 27534825 BLAKE2B 4647b4aac074b10c0d1fb35ddb6b5acefca81c0f2debde04987b5df4e290b14b6406fc922949449aaeea7cf4be371a25c93f8fcb9f67c63d65276340bd586a21 SHA512 6da03193d4fea1e97e35008f59304ab408c521ead8495ba411cde5c172cf953be97999971f57398b813d14f1af1d722539a6b74d5ee54b9e74769ea8258d36ba
EBUILD pyilmbase-2.5.2-r1.ebuild 1484 BLAKE2B 9808e56335ef42c9bc1bfb17e6629b0643ddbecbd5e51068fe56a114146e9a21f0f9ce73410fd5af03001902d649389007e5dd63a5b60044164d94dc3073d403 SHA512 d8c8139249f34803b50a7dc0407dee68518f353bf6b2da9430d15c6c7e1821fcd2b384c0bbb375c9aadbba94731bbb139edda5a80358c49829cf39268e89069d
+EBUILD pyilmbase-2.5.3.ebuild 1529 BLAKE2B daf0059beb24ac52a762359c5c3fa4df26b6d749e990600cfe5b7f84da90bedbbbea80c7bf02707cada717f2ad0b219a1262fe4c8dd17b2fe2dc7d30f9d25641 SHA512 bd199100cf889a81a21da5ddcf39d1861493e150b428d58fe88f1225b246d27dae842028e6ac3f4bef7b1b906111bc44c466600d06db2867eb37ab6df1d5dba6
MISC metadata.xml 652 BLAKE2B a1f5b54cf36def29e3cdc8727b65085b2b83d26bbe0019421cc4b2acc09a027843dbb1ebc5d93bbec9174e1024b496394f9061477b842760048dcd82afc6b347 SHA512 b6e05005a16a6f72261fc1f3d305880b3e073f8a975275e19720742799e1f78fd7e29ac23a589a7724fbab9f4c6cd3b4fe5c81bd309d4532ef94a300e9440840
diff --git a/dev-python/pyilmbase/pyilmbase-2.5.3.ebuild b/dev-python/pyilmbase/pyilmbase-2.5.3.ebuild
new file mode 100644
index 000000000000..d755ffeb1354
--- /dev/null
+++ b/dev-python/pyilmbase/pyilmbase-2.5.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit cmake python-single-r1
+
+DESCRIPTION="IlmBase Python bindings"
+HOMEPAGE="https://www.openexr.com"
+SRC_URI="https://github.com/AcademySoftwareFoundation/openexr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/25"
+KEYWORDS="~amd64 ~x86"
+IUSE="exceptions +numpy test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ ~media-libs/ilmbase-${PV}:=
+ sys-libs/zlib
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.62.0-r1:=[python,${PYTHON_MULTI_USEDEP}]
+ numpy? ( >=dev-python/numpy-1.10.4[${PYTHON_MULTI_USEDEP}] )
+ ')
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-admin/chrpath
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/openexr-${PV}/PyIlmBase"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.2-0001-Fix-pkgconfig-file-for-PyIlmBase-to-include-prefixes.patch
+)
+
+DOCS=( README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Python2=ON
+ -DPYILMBASE_INSTALL_PKG_CONFIG=ON
+ -DPYIMATH_ENABLE_EXCEPTIONS=$(usex exceptions)
+ -DPython3_EXECUTABLE="${PYTHON}"
+ -DPython3_INCLUDE_DIR=$(python_get_includedir)
+ -DPython3_LIBRARY=$(python_get_library_path)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ if use numpy; then
+ python_domodule "${BUILD_DIR}/${EPYTHON/./_}/imathnumpy.so"
+ chmod +x "${D}/$(python_get_sitedir)/imathnumpy.so" || die
+ chrpath -d "${D}/$(python_get_sitedir)/imathnumpy.so" || die
+ fi
+}