summaryrefslogtreecommitdiff
path: root/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /dev-python/pyilmbase/pyilmbase-2.3.0.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'dev-python/pyilmbase/pyilmbase-2.3.0.ebuild')
-rw-r--r--dev-python/pyilmbase/pyilmbase-2.3.0.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild b/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild
index fda4c62db801..f0a627779b31 100644
--- a/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild
+++ b/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -38,10 +38,17 @@ src_prepare() {
}
src_configure() {
+ local boostpython_ver="${EPYTHON:6}"
+ if has_version ">=dev-libs/boost-1.70.0"; then
+ boostpython_ver="${boostpython_ver/./}"
+ else
+ boostpython_ver="-${boostpython_ver}"
+ fi
+
local myeconfargs=(
--with-boost-include-dir="${EPREFIX}/usr/include/boost"
--with-boost-lib-dir="${EPREFIX}/usr/$(get_libdir)"
- --with-boost-python-libname="boost_python-${EPYTHON:6}"
+ --with-boost-python-libname="boost_python${boostpython_ver}"
$(use_with numpy)
)