summaryrefslogtreecommitdiff
path: root/dev-python/pyilmbase/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-python/pyilmbase/files
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-python/pyilmbase/files')
-rw-r--r--dev-python/pyilmbase/files/pyilmbase-2.3.0-fix-build-system.patch48
-rw-r--r--dev-python/pyilmbase/files/pyilmbase-2.3.0-link-pyimath.patch13
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/pyilmbase/files/pyilmbase-2.3.0-fix-build-system.patch b/dev-python/pyilmbase/files/pyilmbase-2.3.0-fix-build-system.patch
new file mode 100644
index 000000000000..bd35f87a0e0f
--- /dev/null
+++ b/dev-python/pyilmbase/files/pyilmbase-2.3.0-fix-build-system.patch
@@ -0,0 +1,48 @@
+diff --git a/configure.ac b/configure.ac
+index 5cbf273..9e80b48 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -4,8 +4,7 @@ AC_SUBST(PYILMBASE_VERSION, 2.3.0)
+ AC_CANONICAL_HOST
+ AC_CONFIG_SRCDIR(PyIex/iexmodule.cpp)
+ AC_CONFIG_HEADER(config/PyIlmBaseConfig.h)
+-AM_INIT_AUTOMAKE(1.6.3) dnl Require automake 1.6.3 or better
+-AM_MAINTAINER_MODE
++AM_INIT_AUTOMAKE
+ dnl static python modules make no sense - disable static
+ AC_DISABLE_STATIC
+
+@@ -20,7 +19,7 @@ dnl Checks for programs.
+ AC_PROG_CXX
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+-AC_PROG_LIBTOOL
++LT_INIT
+ AC_PROG_MAKE_SET
+
+ dnl
+@@ -164,22 +163,13 @@ AC_C_CONST
+ AC_C_INLINE
+ AC_TYPE_SIZE_T
+
+-AC_MSG_CHECKING(for gcc optimization flags)
+-old_cflags=$CFLAGS
+-CFLAGS="$CFLAGS -pipe"
+-AC_TRY_COMPILE([#include <stdio.h>],
+-[ printf ("hello, world"); ],
+-[ EXTRA_OPT_CFLAGS="-pipe"],[ EXTRA_OPT_CFLAGS=""])
+-CFLAGS=$old_cflags
+-AC_MSG_RESULT([$EXTRA_OPT_CFLAGS])
+-
+ dnl Platform-specific stuff
+ case "$host" in
+ *linux*)
+- AC_DEFINE(HAVE_LINUX_PROCFS)
++ AC_DEFINE([HAVE_LINUX_PROCFS], [1], [define on linux])
+ ;;
+ *darwin*)
+- AC_DEFINE(HAVE_DARWIN)
++ AC_DEFINE([HAVE_DARWIN], [1], [define on OSX])
+ ;;
+ esac
+
diff --git a/dev-python/pyilmbase/files/pyilmbase-2.3.0-link-pyimath.patch b/dev-python/pyilmbase/files/pyilmbase-2.3.0-link-pyimath.patch
new file mode 100644
index 000000000000..878c270a885a
--- /dev/null
+++ b/dev-python/pyilmbase/files/pyilmbase-2.3.0-link-pyimath.patch
@@ -0,0 +1,13 @@
+diff --git a/PyImath/Makefile.am b/PyImath/Makefile.am
+index bf87542..ad69515 100644
+--- a/PyImath/Makefile.am
++++ b/PyImath/Makefile.am
+@@ -82,7 +82,7 @@ imathmodule_la_SOURCES = imathmodule.cpp \
+ PyImathBasicTypes.cpp
+
+ imathmodule_la_LDFLAGS = -avoid-version -module
+-imathmodule_la_LIBADD = -lPyImath @BOOST_PYTHON_LIBS@
++imathmodule_la_LIBADD = libPyImath.la @BOOST_PYTHON_LIBS@
+
+ noinst_HEADERS = PyImathFun.h \
+ PyImathBasicTypes.h