summaryrefslogtreecommitdiff
path: root/dev-python/pyifp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyifp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyifp')
-rw-r--r--dev-python/pyifp/Manifest4
-rw-r--r--dev-python/pyifp/files/pyifp-0.2.2-setup-fix.patch11
-rw-r--r--dev-python/pyifp/metadata.xml15
-rw-r--r--dev-python/pyifp/pyifp-0.2.2-r1.ebuild28
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pyifp/Manifest b/dev-python/pyifp/Manifest
new file mode 100644
index 000000000000..f6ba739b3e79
--- /dev/null
+++ b/dev-python/pyifp/Manifest
@@ -0,0 +1,4 @@
+AUX pyifp-0.2.2-setup-fix.patch 513 BLAKE2B f23ae140ffca9cc4de8964d705531d3dc06e75976013ed85b6dc5bf30a850940036d1a9b3fd3b89113b8e2aa202adba24d82d6cd33921c228ecfc54393d1cce0 SHA512 c3c30b89c33e1eebc7bbb8302dcbaeaff0305920695fd526fc6c3838313de4f290564c3d5d4dbb59eb2eb6a2736e9bad718da5009703a4f08db7d4f0f42c6810
+DIST pyifp-0.2.2.tar.gz 21378 BLAKE2B 681b837c13232dedf69c827d0287e7a0e90e532764c6ac8dfc9234b2e957bda9c222db39dc2925f81f0d0bc9b69d6979e9e65377db8c628c195af717275bb3f7 SHA512 9d4b2fc41406c784e8fe9bb650760d750fdf9390b2c69baee1032cc33ffc726ec1a688faa043196a0d075f4e10530dac6637e76b4440b92142f69683cd65a281
+EBUILD pyifp-0.2.2-r1.ebuild 601 BLAKE2B f96e48be2cf5e22f04c3414fb27ecffeeb321fbc14ea2a7a9497550e246548bd4c8d99013ee6328c2b58b85d09c937d1bb64749be679a05d9f32aac21dc493d3 SHA512 a22a88c881d81246a03d7ccd7a719cd828dfd8463fc7fa0cd10a3d80f704cfedccf7eac022111625046f7e6cf300ce0b4155ace7acdae693bb287c6910b86481
+MISC metadata.xml 433 BLAKE2B 256529cd495b1f1869d829698f3e0887c264075477f014a5906e4a70d85ec8079b637c9765e64bded6dc3e9f695f53656f70331694434d09d34fc48dc37bb8b6 SHA512 d747fe4f9127678f0245f2a35d3c8244086a05439c40eaa0e8f6444c6605bbb7c1ee241cd9b22feb06454a972244465e615b5f14e0d158d67c17a0c8ddb3d61c
diff --git a/dev-python/pyifp/files/pyifp-0.2.2-setup-fix.patch b/dev-python/pyifp/files/pyifp-0.2.2-setup-fix.patch
new file mode 100644
index 000000000000..2582e0fd8841
--- /dev/null
+++ b/dev-python/pyifp/files/pyifp-0.2.2-setup-fix.patch
@@ -0,0 +1,11 @@
+--- pyifp-0.2.2/setup.py 2005-02-21 01:36:05.000000000 -0500
++++ pyifp-0.2.2-fixed/setup.py 2005-10-15 13:29:26.000000000 -0400
+@@ -54,7 +54,7 @@
+ self.swig_inc = 'SWIG'
+ self.swig_shadow = None
+
+- def swig_sources(self, sources):
++ def swig_sources(self, sources, extension=None):
+ """Override the definition of 'swig_sources' in build_ext. This
+ is essentially the same function but with better swig support.
+ I will now quote the original docstring:
diff --git a/dev-python/pyifp/metadata.xml b/dev-python/pyifp/metadata.xml
new file mode 100644
index 000000000000..e3560c535fc1
--- /dev/null
+++ b/dev-python/pyifp/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sound@gentoo.org</email>
+ <name>Gentoo Sound project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">ifp-gnome</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyifp/pyifp-0.2.2-r1.ebuild b/dev-python/pyifp/pyifp-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..e5adcfa496b5
--- /dev/null
+++ b/dev-python/pyifp/pyifp-0.2.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libifp library for accessing iRiver iFP devices"
+HOMEPAGE="http://ifp-gnome.sourceforge.net"
+SRC_URI="mirror://sourceforge/ifp-gnome/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libifp-1.0.0.2"
+DEPEND="${RDEPEND}
+ dev-lang/swig"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+PATCHES=( "${FILESDIR}"/${P}-setup-fix.patch )