summaryrefslogtreecommitdiff
path: root/dev-python/pyicu/pyicu-2.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/pyicu/pyicu-2.4.2.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/pyicu/pyicu-2.4.2.ebuild')
-rw-r--r--dev-python/pyicu/pyicu-2.4.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyicu/pyicu-2.4.2.ebuild b/dev-python/pyicu/pyicu-2.4.2.ebuild
new file mode 100644
index 000000000000..f4acff57c10f
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+MY_PN="PyICU"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="https://github.com/ovalhub/pyicu"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/icu:="
+DEPEND="${RDEPEND}"
+BDEPEND="test? (
+ ${RDEPEND}
+ dev-python/six
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.2-testLocaleMatcher_pytest_old_icu.patch
+)
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=(CHANGES CREDITS README.md)
+
+distutils_enable_tests pytest