summaryrefslogtreecommitdiff
path: root/dev-python/pyicu/pyicu-2.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-18 00:01:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-18 00:01:42 +0100
commit075fd1f8cabc5879c6eb42127fb84c3058677fde (patch)
tree8b761e85416656264e041b1954427a58894b3333 /dev-python/pyicu/pyicu-2.12.ebuild
parent6c9dc10e04cd513437e046ccca0e51a3d6d4dc7c (diff)
gentoo auto-resync : 18:05:2024 - 00:01:41
Diffstat (limited to 'dev-python/pyicu/pyicu-2.12.ebuild')
-rw-r--r--dev-python/pyicu/pyicu-2.12.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/pyicu/pyicu-2.12.ebuild b/dev-python/pyicu/pyicu-2.12.ebuild
deleted file mode 100644
index 5b2f1fee5d3b..000000000000
--- a/dev-python/pyicu/pyicu-2.12.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=${P/-/-v}
-DESCRIPTION="Python bindings for dev-libs/icu"
-HOMEPAGE="
- https://gitlab.pyicu.org/main/pyicu/
- https://pypi.org/project/PyICU/
-"
-SRC_URI="
- https://gitlab.pyicu.org/main/pyicu/-/archive/v${PV}/${MY_P}.tar.bz2
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
-
-DEPEND="
- dev-libs/icu:=
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- test? (
- dev-python/six[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( CHANGES CREDITS README.md )
-
-distutils_enable_tests pytest
-
-python_test() {
- epytest test
-}