summaryrefslogtreecommitdiff
path: root/dev-python/pyicu/pyicu-2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
commit586819755b4dbfdffdc8a725ab7c0f86095b8489 (patch)
treed6790c838cfe9607c996e4913fdf11bad5fdd528 /dev-python/pyicu/pyicu-2.1.ebuild
parent3f71901f8c228f4de570abed1831ce3ee425343e (diff)
gentoo resync : 15.09.2018
Diffstat (limited to 'dev-python/pyicu/pyicu-2.1.ebuild')
-rw-r--r--dev-python/pyicu/pyicu-2.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pyicu/pyicu-2.1.ebuild b/dev-python/pyicu/pyicu-2.1.ebuild
new file mode 100644
index 000000000000..381c93d7b92c
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="PyICU"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="https://github.com/ovalhub/pyicu"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/icu"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest
+ dev-python/six )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=(CHANGES CREDITS README.md)
+
+python_prepare_all() {
+ # bug 651748
+ # due to ICU 59 requiring C++11 now
+ append-cxxflags -std=c++11
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if [[ ${EPYTHON} == python2* ]]; then
+ # See Bug #644226
+ ewarn "Skipping tests for ${EPYTHON} because they are known to fail"
+ else
+ esetup.py test
+ fi
+}