summaryrefslogtreecommitdiff
path: root/dev-python/pyhcl/pyhcl-0.4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/pyhcl/pyhcl-0.4.4.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/pyhcl/pyhcl-0.4.4.ebuild')
-rw-r--r--dev-python/pyhcl/pyhcl-0.4.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyhcl/pyhcl-0.4.4.ebuild b/dev-python/pyhcl/pyhcl-0.4.4.ebuild
new file mode 100644
index 000000000000..f3342b15ce58
--- /dev/null
+++ b/dev-python/pyhcl/pyhcl-0.4.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+# This value is obtained by running the following on the checked out
+# tag:
+# git describe --tags --long
+LONG_VERSION=0.4.4-0-g314cd32
+PYTHON_COMPAT=( python3_8 python3_9 )
+inherit distutils-r1
+
+DESCRIPTION="HCL configuration parser for python"
+HOMEPAGE="https://github.com/virtuald/pyhcl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/virtuald/pyhcl.git"
+else
+ SRC_URI="https://github.com/virtuald/pyhcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MPL-2.0"
+SLOT="0"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ printf '__version__ = "%s"\n' "${LONG_VERSION}" > src/hcl/version.py || die
+}