summaryrefslogtreecommitdiff
path: root/dev-python/pyhamcrest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/pyhamcrest
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/pyhamcrest')
-rw-r--r--dev-python/pyhamcrest/Manifest2
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-2.0.3.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyhamcrest/Manifest b/dev-python/pyhamcrest/Manifest
index 5b7a3085676a..13d2b4090db2 100644
--- a/dev-python/pyhamcrest/Manifest
+++ b/dev-python/pyhamcrest/Manifest
@@ -1,3 +1,5 @@
DIST PyHamcrest-2.0.2.gh.tar.gz 55491 BLAKE2B 749f227b8cb1180a64e24cdbf97b6f610b9871b21215a761642d19fdd43ad8e175718b12cfb0de2cdb5c6ae8c3c5271e04b7c3b489e01ac689769e24202ece56 SHA512 d6e510ca1e6533b425b424d411e23c4ee2a6bad2d635695e4e68f991fbdc57269c3a433361e431cb5dda7891278951d5de7a05f5c1c167714eecdaf74644d1c8
+DIST PyHamcrest-2.0.3.gh.tar.gz 59353 BLAKE2B b393f250f1a5f3f2d3014ae8a6e20ec659e034d8e681fcbb16f4e9fbe69ba7a94ce342a79584cfc99dff6af57e1d9763efd5ff8b5d891951289d9047cab4270c SHA512 4a28c0ae04db11a86c44dff001e919a5bb6b820af8ffd60b1a1f2846f257d79daac76fbdeac4a0039d149e643043258a0685382a3a4b52c6d4586b8be95e1657
EBUILD pyhamcrest-2.0.2.ebuild 765 BLAKE2B bc7dd401630a9b05911ed3b25f84a1dbc980bb7bb1ae7f200e9acb8945a09c52ce08963b854fed7d49dd715c66dc608b30530e16e5dc434efa46874b63d7f474 SHA512 a1355f20b7ed7cce9148f09ca652b14648682b589256e488e951ca87744d3c5eae17471ab18233628313873dd5f371b34f1fa7980eddddc742915337bdc98c4a
+EBUILD pyhamcrest-2.0.3.ebuild 766 BLAKE2B 85aafc90e40827fdab5718bc34a3896ebe6918803a3e6a62035e4a7cce07ea3cc2e5f1af74f1984da2f1a4ef942ede93ff51859f5309807ebbdccd220bf2e2fe SHA512 973c45d174235e4fd71dcc2fc67e4d3d1e28f8454d093d15741f086c58829a1180c22da9ed3cadf250224af340e509f7df630e967f73e36bdd2c1bc164ca0703
MISC metadata.xml 397 BLAKE2B cfdb950c34749dd9fa17d822df0194a8f35e477902947cf568f76aed96588c0e5a903ea5448f9772faef06ddc66df3c3c971978c6f4431861bf3586702d610db SHA512 024f24f466f0212a7ac599638bcd42b858e2cc786b7bf2641d0e0d4cc3df5dc97c958d4d85930cbd1c32e023f755f844a2675e2c820839729c54ad5e8fb40cd6
diff --git a/dev-python/pyhamcrest/pyhamcrest-2.0.3.ebuild b/dev-python/pyhamcrest/pyhamcrest-2.0.3.ebuild
new file mode 100644
index 000000000000..d7f479376a63
--- /dev/null
+++ b/dev-python/pyhamcrest/pyhamcrest-2.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P="PyHamcrest-${PV}"
+DESCRIPTION="Hamcrest framework for matcher objects"
+HOMEPAGE="https://github.com/hamcrest/PyHamcrest"
+SRC_URI="
+ https://github.com/hamcrest/PyHamcrest/archive/V${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="examples"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}