summaryrefslogtreecommitdiff
path: root/dev-python/pyhamcrest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/pyhamcrest
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/pyhamcrest')
-rw-r--r--dev-python/pyhamcrest/Manifest2
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild34
2 files changed, 28 insertions, 8 deletions
diff --git a/dev-python/pyhamcrest/Manifest b/dev-python/pyhamcrest/Manifest
index 397472340c2b..d7749d5c523f 100644
--- a/dev-python/pyhamcrest/Manifest
+++ b/dev-python/pyhamcrest/Manifest
@@ -1,5 +1,5 @@
DIST PyHamcrest-1.9.0.gh.tar.gz 57650 BLAKE2B c497688f03ec3b072d8ab076fc096a442d5cbbd94493eae57779879ccb6f281477aeeb7f7a67e539442010e60194f9f04a6deddd1d2267e9743742b45433f124 SHA512 3a878637ed5138365416c170871a63640f089047b723c7ec8db893dd716c0b1cdad16a98584700405693b954af7d4868a8543d1a3fc58ded22b493c8c61661b4
DIST PyHamcrest-1.9.0.tar.gz 376623 BLAKE2B 808c74aa4dff89467c126cbc0e18029a9504cb27bbf03662a90666f85c76d7d7617260f50d35acde3a8e9e437b846589423cbb3697f8ceb86d0b5b838c586ebd SHA512 3b8393d0079b619b208ec7f06ed5133c4ff9d9dba050f818adf56347fc2225fd1c85d60f3dc262b7b9722061f0b8e4966180b6b96245a371e578d0d51633b4b0
-EBUILD pyhamcrest-1.9.0-r1.ebuild 1328 BLAKE2B ab20bcb833bd550a0e7fb99b1d2dede32d7ff9c831a7e3128080199e7850472c6ddf3990366c77362d8e4b425f4c3bcba33caa5ef01b867cd56c882a58eff05c SHA512 f1c6d4abe4c7a67668ff00b2cf5606dfe3ee0d9e0780a6ba4010f8bc380727262dff67d0b023f0bd60e114e4dc43e9976f6a1ebe11a5ed359086878849a42765
+EBUILD pyhamcrest-1.9.0-r1.ebuild 2083 BLAKE2B 4d97c0cef51458dcf1868f306b5a4d2266f0e8c8f910890ad0abf022a8a473650280896fb1ca8900d2a3456d5a9d6ec54bd29e82cf4450cf65a1d3d9aab40aa0 SHA512 c8a445ae58fdf6d7c0fc3fe13d25fae1290c72f6b8a5be821fdb946cb8d0dd162d8dd2909e205e040b0ceffcff8c69e10c8e33dfcb084e366b7b0c524dff4560
EBUILD pyhamcrest-1.9.0.ebuild 1222 BLAKE2B 5b50d8b8823b1d399ae78ca675b6ec9eeb7235b6fc1c59c70057148d0ecfaa3a47bb907411ada7a965d1ba42672fac671379e129f5d035175d05d01816b6bd69 SHA512 eee23278b27afc96cefb11410a48a76fb23daf64b826d66c16756a949ee7cd2e18229950cfbea1778f3629eb46df837446127511cedea8c33c8c400fff707556
MISC metadata.xml 297 BLAKE2B 1d304f6e46130d706190ceaa75f188fba8b3934ebcb42b48d7209f9a9dc67e3561cc2a823b9a591cd58a945161c382698178979e4dacf776178367e43c5519a7 SHA512 999f2517a446b5911d475789246dcb70a08566fba9ecec5f2b69fa29180fdfbb17f4f24b4c87ef71c422814bf7502da2812e5c7938293e96affe721d92e428fd
diff --git a/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild b/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
index 9d46ea1df2dc..4e29ae715def 100644
--- a/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
+++ b/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit distutils-r1
@@ -14,15 +15,17 @@ SRC_URI="https://github.com/hamcrest/PyHamcrest/archive/V${PV}.tar.gz -> ${MY_PN
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~sh ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 ~arm arm64 ~mips ~sh ~amd64-linux ~x86-linux"
IUSE="doc examples test"
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags -3) ) )"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/six-1.4[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
doc? (
- >=dev-python/sphinx-1.2.2[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/sphinx-2[${PYTHON_USEDEP}]' -3)
+ $(python_gen_cond_dep 'dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]' -3)
)
test? (
>=dev-python/pytest-2.6[${PYTHON_USEDEP}]
@@ -31,24 +34,41 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_PN}-${PV}"
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( -3 )
+}
+
python_prepare_all() {
# enables coverage testing which we don't want
rm pytest.ini || die
+
+ # Known test failures. Remove them for now.
+ rm tests/hamcrest_unit_test/base_description_test.py || die "removing test #1 failed"
+ rm tests/hamcrest_unit_test/core/is_test.py || die "removing test #2 failed"
+ rm tests/hamcrest_unit_test/core/isinstanceof_test.py || die "removing test #3 failed"
+
+ # These fail on HPPA. Drop them too.
+ if use hppa; then
+ rm tests/hamcrest_unit_test/base_matcher_test.py || die "removing test #4 failed"
+ rm tests/hamcrest_unit_test/core/described_as_test.py || die "removing test #5 failed"
+ fi
+
distutils-r1_python_prepare_all
}
python_compile_all() {
- use doc && esetup.py build_sphinx
+ if use doc; then
+ esetup.py build_sphinx
+ HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ fi
}
python_test() {
py.test -vv || die "Tests failed under ${EPYTHON}"
- "${PYTHON}" tests/object_import.py || die "Tests failed under ${EPYTHON}"
+ "${EPYTHON}" tests/object_import.py || die "Tests failed under ${EPYTHON}"
}
python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
use examples && dodoc -r examples
-
distutils-r1_python_install_all
}