summaryrefslogtreecommitdiff
path: root/dev-python/pyhamcrest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
commit520a5b56dff7c24c9d42eafec142cb78b44f8e3e (patch)
treef562f705600dbd2292e97c0b4145787c2a8d1f97 /dev-python/pyhamcrest
parent3811bc3072bf19e2be351d2c63f81532945c0f21 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'dev-python/pyhamcrest')
-rw-r--r--dev-python/pyhamcrest/Manifest2
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pyhamcrest/Manifest b/dev-python/pyhamcrest/Manifest
index 165c61418366..b6787daf8393 100644
--- a/dev-python/pyhamcrest/Manifest
+++ b/dev-python/pyhamcrest/Manifest
@@ -1,3 +1,5 @@
+DIST PyHamcrest-1.9.0.gh.tar.gz 57650 BLAKE2B c497688f03ec3b072d8ab076fc096a442d5cbbd94493eae57779879ccb6f281477aeeb7f7a67e539442010e60194f9f04a6deddd1d2267e9743742b45433f124 SHA512 3a878637ed5138365416c170871a63640f089047b723c7ec8db893dd716c0b1cdad16a98584700405693b954af7d4868a8543d1a3fc58ded22b493c8c61661b4
DIST PyHamcrest-1.9.0.tar.gz 376623 BLAKE2B 808c74aa4dff89467c126cbc0e18029a9504cb27bbf03662a90666f85c76d7d7617260f50d35acde3a8e9e437b846589423cbb3697f8ceb86d0b5b838c586ebd SHA512 3b8393d0079b619b208ec7f06ed5133c4ff9d9dba050f818adf56347fc2225fd1c85d60f3dc262b7b9722061f0b8e4966180b6b96245a371e578d0d51633b4b0
+EBUILD pyhamcrest-1.9.0-r1.ebuild 1305 BLAKE2B f0e3442a34033acc4269fd99f31c30970562a1be310ddeec79100b3b98e02201034c5007a14cf933c62402491bc7b52e70f86bd6f1a1d3dbfb304796ae00d6e6 SHA512 951545d5bba89d4a64620bc06346427643575ca0985d48d5594343be19e2383bb3bb391b3ffd303b39cf96128428ec19dbfb9d74a7fecfac93c05df3fc011b22
EBUILD pyhamcrest-1.9.0.ebuild 1227 BLAKE2B 173ad0e42c44e083043203c40435865697bf5222e7bd4fe907db296fbea627aa06de8a99dd8842f259073ecedbd902a4bc7c9eaf7b74540e1afe53d85832612d SHA512 4bca028ef12f224a122978f6ca9ed259306b7817f5f6182cd462d366b944458bf2657ff7a25f2993582d69cd9e5780004b65702062c2f6cbe429f6c39eefb81d
MISC metadata.xml 271 BLAKE2B c9035b9fb7a0fca1355aeda317feceecac5790bb6723360063b236d6633a040a594eea8f304c3b5bc8e918b1781f0e5e887ec15225d51a021592391195b7e8ff SHA512 89f447b79dadbb441c4c51527f486fcf7110b67c0a86c9fe6413c563463be57089faa1ddb36701080c368ff0a8442532bc774602e0120cd5466a4d7fb6bb6e0d
diff --git a/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild b/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
new file mode 100644
index 000000000000..772b9f693b9e
--- /dev/null
+++ b/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="PyHamcrest"
+
+DESCRIPTION="Hamcrest framework for matcher objects"
+HOMEPAGE="https://github.com/hamcrest/PyHamcrest"
+SRC_URI="https://github.com/hamcrest/PyHamcrest/archive/V${PV}.tar.gz -> ${MY_PN}-${PV}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-fbsd"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/six-1.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/sphinx-1.2.2[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/pytest-2.6[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ # enables coverage testing which we don't want
+ rm pytest.ini || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ py.test -vv || die "Tests failed under ${EPYTHON}"
+ "${PYTHON}" tests/object_import.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}