summaryrefslogtreecommitdiff
path: root/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild')
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild b/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
index 46bbf1b22e5f..6c7080cb324b 100644
--- a/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
+++ b/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
inherit distutils-r1
@@ -21,9 +21,9 @@ IUSE="examples test"
RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/six-1.4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
test? (
+ ${RDEPEND}
>=dev-python/pytest-2.6[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)"
@@ -50,7 +50,7 @@ python_prepare_all() {
}
python_test() {
- py.test -vv || die "Tests failed under ${EPYTHON}"
+ pytest -vv || die "Tests failed under ${EPYTHON}"
"${EPYTHON}" tests/object_import.py || die "Tests failed under ${EPYTHON}"
}