summaryrefslogtreecommitdiff
path: root/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild')
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild b/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
deleted file mode 100644
index 6c7080cb324b..000000000000
--- a/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6..9} )
-
-inherit distutils-r1
-
-MY_PN="PyHamcrest"
-
-DESCRIPTION="Hamcrest framework for matcher objects"
-HOMEPAGE="https://github.com/hamcrest/PyHamcrest"
-SRC_URI="https://github.com/hamcrest/PyHamcrest/archive/V${PV}.tar.gz -> ${MY_PN}-${PV}.gh.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/six-1.4[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- ${RDEPEND}
- >=dev-python/pytest-2.6[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx doc \
- dev-python/sphinx_rtd_theme
-
-python_prepare_all() {
- # enables coverage testing which we don't want
- rm pytest.ini || die
-
- # Known test failures. Remove them for now.
- rm tests/hamcrest_unit_test/base_description_test.py || die "removing test #1 failed"
- rm tests/hamcrest_unit_test/core/is_test.py || die "removing test #2 failed"
- rm tests/hamcrest_unit_test/core/isinstanceof_test.py || die "removing test #3 failed"
-
- # These fail on HPPA. Drop them too.
- if use hppa; then
- rm tests/hamcrest_unit_test/base_matcher_test.py || die "removing test #4 failed"
- rm tests/hamcrest_unit_test/core/described_as_test.py || die "removing test #5 failed"
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pytest -vv || die "Tests failed under ${EPYTHON}"
- "${EPYTHON}" tests/object_import.py || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}