summaryrefslogtreecommitdiff
path: root/dev-python/pyh2o
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/pyh2o
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/pyh2o')
-rw-r--r--dev-python/pyh2o/Manifest3
-rw-r--r--dev-python/pyh2o/pyh2o-1.ebuild (renamed from dev-python/pyh2o/pyh2o-9999.ebuild)15
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-python/pyh2o/Manifest b/dev-python/pyh2o/Manifest
index 6dc39471a04c..6100cafd5aba 100644
--- a/dev-python/pyh2o/Manifest
+++ b/dev-python/pyh2o/Manifest
@@ -1,2 +1,3 @@
-EBUILD pyh2o-9999.ebuild 429 BLAKE2B 0c077a6545a33590053deab7d7bcb9d540b1e35e59abd86e1246fd0c4e24d2ef6b5220edd8431706cf7c44bb672a4fe289ebb27d46cd2b68149607d60deb9514 SHA512 b41b184fa6fd861bb206dfffcdb6f134e10e528f5e40b0bdac0f727eeb69bbe04c4241d1b583c7cc84e3307b19495278b5da015eec15f86d40ee25636e3e6c0d
+DIST pyh2o-1.tar.gz 7327 BLAKE2B 9d6b308d17dd799e2c83a191c346a3d78fc0a097de2a2fd5cb6277a1525992aa18f6c6b61b2c2503ae4a9e7ddd3575e092aef77a0e84223a5a2c702c0a808f1d SHA512 529fa4d8e9c477346fcbd23d7172d41de96789797f0e1ad0557f4c0bdaea8a519a8e8735845d0080cf171182874ce0819e76357ca7c7db1d62a9544f907095db
+EBUILD pyh2o-1.ebuild 502 BLAKE2B dbbe572d0d8ec7d143c35b06d2aa7fd4123d23f45d4d17b546e83a1bd15b0a1d01a5d12e95b102e7d40356e64c542a10f8f03c7565de4976a759f6bdbf634ef9 SHA512 2434a534b3b73d711041d11a0b9da9e91ca3a4758908e4fc1004209029ae60b29646da6460d6e410d8e32b9b8279055e9bbed4511618c61b36c84e3414613370
MISC metadata.xml 521 BLAKE2B 6f0fd3f19c783f63615643e3f0ff35cad870fa4ea16e4f111b645da056b0984f95ec9f886128c40e0d85ebcddde6768575652021b4c3f9db206a5ca8b5a05b31 SHA512 dff927c256adb5963ae243715b8a50dafece0ee94fb8a7bb416b7d8e2801cb4d6380412ae6ce36866fa27b403f487a1158a5919fc7ba727174ecfd9d5d10e7ec
diff --git a/dev-python/pyh2o/pyh2o-9999.ebuild b/dev-python/pyh2o/pyh2o-1.ebuild
index 1da3c13679c3..f8392f678f6c 100644
--- a/dev-python/pyh2o/pyh2o-9999.ebuild
+++ b/dev-python/pyh2o/pyh2o-1.ebuild
@@ -2,19 +2,22 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit distutils-r1 git-r3
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
DESCRIPTION="Python API for sci-libs/libh2o"
HOMEPAGE="https://github.com/mgorny/pyh2o/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/mgorny/pyh2o.git"
+SRC_URI="
+ https://github.com/mgorny/pyh2o/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
-IUSE=""
+KEYWORDS="~amd64 ~x86"
RDEPEND=">=sci-libs/libh2o-0.2.1:="
DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest