summaryrefslogtreecommitdiff
path: root/dev-python/pygresql
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /dev-python/pygresql
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'dev-python/pygresql')
-rw-r--r--dev-python/pygresql/Manifest4
-rw-r--r--dev-python/pygresql/pygresql-5.0.4.ebuild4
-rw-r--r--dev-python/pygresql/pygresql-5.0.6.ebuild32
3 files changed, 37 insertions, 3 deletions
diff --git a/dev-python/pygresql/Manifest b/dev-python/pygresql/Manifest
index 1c24d1e147b5..4906e0ab1c58 100644
--- a/dev-python/pygresql/Manifest
+++ b/dev-python/pygresql/Manifest
@@ -1,3 +1,5 @@
DIST PyGreSQL-5.0.4.tar.gz 637569 BLAKE2B 3f7bddb8b5e455ca4f181d254d4d125b89a64d7aaa1440b9ab5d916c395b9d93fc9814269992c134b6fd8a81f436752dbe4d7c06125e683a5257361d428c6a6f SHA512 f177ca3b023c007dafe80369b86a1742ff334137e493c3c19ac8bda0181d2543cd2431b8ab8d2d43f30d681121324bc4f236a9ebbddf1e927b071db7c9b34ea6
-EBUILD pygresql-5.0.4.ebuild 718 BLAKE2B 9d1729500f651809825cf91647736bd9c6fc096f77755fe5400200adafb9325699be202dc0144cfbc45a573c1c4dfbd75384a16334463ddb1de0e9168bf1c134 SHA512 61c8ccd1da12803cebaf112b453d414df85e035ebee4d909ab3deecd8402df206a11361a22badf9a5d752503e37faa29b5f998ba8c7c60db8b3f918c397410dc
+DIST PyGreSQL-5.0.6.tar.gz 648481 BLAKE2B 7e1d96b5c09a3d2f0e412504be27fcfa557804ace8a4c24d657f586a8e647f5001da943543d49f6d2bdec48a34017b7379305fb760436065ba7f36ce981d85c2 SHA512 fb42f462d749f824f52dd424464ecc3591e615e7e0d220a63a217797aeb3f05379fab071480946d09779dbdb9028351a596160989066589dde1be18f7d320ac8
+EBUILD pygresql-5.0.4.ebuild 714 BLAKE2B 9365cf32ddb6a06926680bb38ecb93de0d1061e2955978b7d3adac5fbe4c0161e712ab73f577afe2aa0cadb16fd2c6432712b485c9bb30831778a431777a2415 SHA512 9a08e9e54ed38286f4ad3004baa36be5ca1f0b54dd0181ced529a301dd4aa7a6b42e9dc75ab1afec18c2849f1936670fd86b9a426dbc2e9bae507d85e5aea7b8
+EBUILD pygresql-5.0.6.ebuild 685 BLAKE2B 2796a98d19d8941e40bf58288bd956c33556abe45fea2840db4208fd99f6ad43b75e3303511c7544909edca69be797d8ff58f95ae8f6d092f058f5643732c3b2 SHA512 32606c0aa6dcf66f8d9f8582eada44f2e5fa1cc990784f236122a33ec826f744b9bb03720dc3d588ca47eab0f6266f9d262966c39acf265b37e47a3a51e3efa3
MISC metadata.xml 452 BLAKE2B 8d60fd06e68e39b5d373f30fec25979a0a67c51eee216425e382b559b908ccd12e425c95995dfd28d8487fb306f03fa10d8a71320a4ff5ebd6349e887af624e9 SHA512 f6877e2fd8cb2b6606a29e421d0f0ab4fd66a5e7446a4307718d1c0435c2e8ab3c59db795ca1e18e58eb79d0474c57bf35a3d0544095d2d7d618cf25e96ff55f
diff --git a/dev-python/pygresql/pygresql-5.0.4.ebuild b/dev-python/pygresql/pygresql-5.0.4.ebuild
index 02d9d5b7bc8d..dd8ec73329cd 100644
--- a/dev-python/pygresql/pygresql-5.0.4.ebuild
+++ b/dev-python/pygresql/pygresql-5.0.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,7 @@ SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.tar.gz"
LICENSE="POSTGRESQL"
SLOT="0"
-KEYWORDS="alpha amd64 ~hppa ia64 ppc sparc x86"
+KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86"
IUSE=""
REQUIRED_USE="${POSTGRES_REQ_USE}"
diff --git a/dev-python/pygresql/pygresql-5.0.6.ebuild b/dev-python/pygresql/pygresql-5.0.6.ebuild
new file mode 100644
index 000000000000..1647a3dc50ca
--- /dev/null
+++ b/dev-python/pygresql/pygresql-5.0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+POSTGRES_COMPAT=( 9.{3..6} 10 )
+PYTHON_COMPAT=( python2_7 python3_{4..7} )
+
+inherit distutils-r1 postgres
+
+MY_P="PyGreSQL-${PV}"
+
+DESCRIPTION="A Python interface for the PostgreSQL database"
+HOMEPAGE="http://www.pygresql.org/"
+SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="${POSTGRES_DEP}"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ local DOCS=( docs/*.rst docs/community/* docs/contents/tutorial.rst )
+
+ distutils-r1_python_install_all
+}