summaryrefslogtreecommitdiff
path: root/dev-python/pygresql/pygresql-5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
commit7a86906b67693cc65671d3e1476835d3a7e13092 (patch)
tree9de1b9e2cf77833183d4e5ffab2e94d0403ef725 /dev-python/pygresql/pygresql-5.1.ebuild
parentd56d144655e3785864da43c9acb6c228ef9360ae (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'dev-python/pygresql/pygresql-5.1.ebuild')
-rw-r--r--dev-python/pygresql/pygresql-5.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pygresql/pygresql-5.1.ebuild b/dev-python/pygresql/pygresql-5.1.ebuild
new file mode 100644
index 000000000000..1f1d7861a4f3
--- /dev/null
+++ b/dev-python/pygresql/pygresql-5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+POSTGRES_COMPAT=( 9.{4..6} {10..11} )
+PYTHON_COMPAT=( python2_7 python3_{5..7} )
+
+inherit distutils-r1 postgres
+
+MY_P="PyGreSQL-${PV}"
+
+DESCRIPTION="A Python interface for the PostgreSQL database"
+HOMEPAGE="http://www.pygresql.org/"
+SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND="${POSTGRES_DEP}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed "s/, '-Wall'//" -i setup.py || die
+ default
+}
+
+python_install_all() {
+ local DOCS=( docs/*.rst docs/community/* docs/contents/tutorial.rst )
+
+ distutils-r1_python_install_all
+}