summaryrefslogtreecommitdiff
path: root/dev-python/pygresql/pygresql-5.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-18 18:38:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-18 18:38:22 +0000
commita5956e0a0daddcad648e0d8d8e5cb3e49e09bda7 (patch)
tree3d2e0a61f348a5299e73ca7c2b236156a8cc79b5 /dev-python/pygresql/pygresql-5.0.4.ebuild
parent38f60b3ec9ff175535d9a056a76ae42931e61e21 (diff)
gentoo resync : 18.11.2017
Diffstat (limited to 'dev-python/pygresql/pygresql-5.0.4.ebuild')
-rw-r--r--dev-python/pygresql/pygresql-5.0.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pygresql/pygresql-5.0.4.ebuild b/dev-python/pygresql/pygresql-5.0.4.ebuild
new file mode 100644
index 000000000000..5aa6ec1e3a2e
--- /dev/null
+++ b/dev-python/pygresql/pygresql-5.0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+POSTGRES_COMPAT=( 9.{3..6} 10 )
+PYTHON_COMPAT=( python2_7 python3_{4..6} )
+
+inherit distutils-r1 postgres
+
+MY_P="PyGreSQL-${PV}"
+
+DESCRIPTION="A Python interface for the PostgreSQL database"
+HOMEPAGE="http://www.pygresql.org/"
+SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="${POSTGRES_DEP}"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ local DOCS=( docs/*.rst docs/community/* docs/contents/tutorial.rst )
+
+ distutils-r1_python_install_all
+}