summaryrefslogtreecommitdiff
path: root/dev-python/pygraphviz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-20 14:38:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-20 14:38:48 +0100
commitdd45cee79a4c905271356e96af531293b62c429b (patch)
treebadf99f89a2e65ae16720e8c67fad03183873dd0 /dev-python/pygraphviz
parent32fc5f4a2c2017f1f9c628fab9dcb5a54c3e6f03 (diff)
gentoo auto-resync : 20:08:2022 - 14:38:48
Diffstat (limited to 'dev-python/pygraphviz')
-rw-r--r--dev-python/pygraphviz/Manifest2
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.10.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pygraphviz/Manifest b/dev-python/pygraphviz/Manifest
index 625601141eaf..631c4a5219f0 100644
--- a/dev-python/pygraphviz/Manifest
+++ b/dev-python/pygraphviz/Manifest
@@ -1,3 +1,5 @@
+DIST pygraphviz-1.10.zip 120582 BLAKE2B 965b84ec6951c364084ddde4f0594ad7c14eb7e884062ad4f24042b6298b9caf10b3aa33eecfe8154c87c4bfd8d3651acc586129b019aef8b809130d69c03f82 SHA512 571c35f7a8013d5f128fcfbbd68372c8660560847afa0648737eae6d305a9283b69dce23a1b1aeb808bd4eac9c9cefa72b1d358fbc47b724a0b70997ea3f6d84
DIST pygraphviz-1.9.zip 119946 BLAKE2B a399742ae5e8323eec0b6890858cc9158c2942c4f0adb8c74fbfb9745321ae013b93227540e5c328f5dd22d8fba2cf9217a9079f99a14feb983d7188e07084c9 SHA512 0a963b2cfe526c5444379b037797504380898c300256ab3b4800687f46b6230d8bc0adb5f499004a8009544c6cc804221689921c08a4f4b71b86ae01dc39cb7e
+EBUILD pygraphviz-1.10.ebuild 976 BLAKE2B 5ce88207a72b9928b8808057ac0606af8e65fb86fdc9ab8d58dd4188e4814ef62c4d029d6a7054ee3e8fe0d6f32a10335aadc62b8edbb2eeb1f0c2f11dc41d8d SHA512 a8b332cc11b46828b58fba2f9aa418388788d182f19f8aa2e03569c40cda0bb463beb87b88bf7c6391f01cc55102a090d1cab6633db24ee7dd0a90c945b7e768
EBUILD pygraphviz-1.9.ebuild 973 BLAKE2B 38e56a0ba861bc6d996384770ec122ea8714a1674b004d78929a5f4770d49a2d58cc607a59b387cd35adeb956362ee1cb38573d9a67875ce371065684150ab1d SHA512 a7a349ca26ec994ae984e26657a3ecabb27fe41b6443186a9bebabe94c7b89007d45df3e7fcfd5242aa9fcf6945153a837a66c3f5ea235f89912fef53a370273
MISC metadata.xml 680 BLAKE2B 8c27b9bad68a0cbad1f63ad26052eef28e3446b0833bd2f87600737e763c7438cc3ac3f956c0e2a7964a7962d63dc0b7c5cc0cd8e6d61e6eb653e78044f9dd45 SHA512 7ee41b408d35f114dacb3ab9fd4ccd846ea6a4c865266d9bcb58988c464a0282e9dd2e9dc2e6c3f5a264dc93d4ba59a2e0bf27e9003b97e02b37dede273e17da
diff --git a/dev-python/pygraphviz/pygraphviz-1.10.ebuild b/dev-python/pygraphviz/pygraphviz-1.10.ebuild
new file mode 100644
index 000000000000..96a80374fe2b
--- /dev/null
+++ b/dev-python/pygraphviz/pygraphviz-1.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
+HOMEPAGE="https://pygraphviz.github.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x86-linux ~ppc-macos ~x64-macos"
+
+# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
+RDEPEND="media-gfx/graphviz"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/unzip
+ dev-lang/swig:0
+ test? ( dev-python/doctest-ignore-unicode[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ swig -python pygraphviz/graphviz.i || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/install || die
+ epytest
+}
+
+python_install_all() {
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+
+ distutils-r1_python_install_all
+}