summaryrefslogtreecommitdiff
path: root/dev-python/pygraphviz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-09 13:01:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-09 13:01:22 +0000
commitc6985b401141ea8b5ec4b95c4ad3a5a21ef32571 (patch)
tree56249d49d47e3dde9d3298ed175d983defedf23b /dev-python/pygraphviz
parent6790f1eddc7029fda1a6bae94751a4ff1eb57776 (diff)
gentoo auto-resync : 09:01:2024 - 13:01:22
Diffstat (limited to 'dev-python/pygraphviz')
-rw-r--r--dev-python/pygraphviz/Manifest2
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.12.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pygraphviz/Manifest b/dev-python/pygraphviz/Manifest
index 9591fac1fd00..a786edaa49b5 100644
--- a/dev-python/pygraphviz/Manifest
+++ b/dev-python/pygraphviz/Manifest
@@ -1,3 +1,5 @@
DIST pygraphviz-1.11.zip 120803 BLAKE2B 004312750bcb9fab5c39af2c1de6c452489d9a2deea8211e6bb7cd722e9043070644b61c78047b01d649d41194441d82ffe2dde9fb17b6d9233bd0acee539c7e SHA512 3914d29fb214e1f7d59c7849e1e63e783902acd262912eccffbf6a67f8cbf6f540b9f2e84c9e7b4f0d90fae27f451a701a3b75a4dcb15b8a81bed463b34e2ef2
+DIST pygraphviz-1.12.tar.gz 104941 BLAKE2B 5c2d119c66837d13511ef4756093b159f45ccb2888eb2b86c1d016837059ed34bdc5cb7e69eeff013642d92ec0c2b4a1149316b0baaa742c49a34945fd2563e0 SHA512 2407fdd7de3b2f7f1d9f9e3e3fe0f19c4faad4a72db33a0b4341a01f98eecd4d240079f2d0ea5cf68a5e10236f11fd84e55fd44518611efde2fab7590e3aae90
EBUILD pygraphviz-1.11.ebuild 1022 BLAKE2B a4765eb618bef2346105cf87a442a765678cf9ee5be8f52756a12fffd5f4a61ab7249ff7dea4bf7c0775892082169bbf40093013f4c02ced24cb4d47f87a321c SHA512 979208df0b327186f298076f14933edb319b3786a895729b491a394b9fef3dd3f0fb5a3561a9e6380af24f89eb5534746abe979f2e80a8a60237098647c6afc9
+EBUILD pygraphviz-1.12.ebuild 960 BLAKE2B 80bac24efe6b6bc1474a0a1a1a5e1d775aeeedff18ee41b65a7fbf2829dbbc71ee5070f70f63ee2e94d27040ea985c4663e54745b79b6037b18eb20984f5a929 SHA512 9f9438e941b643cae482ca132a7b8cd67f4e101a58c487bc2a584be5d1c4b13132bb8247fa13d56082b0beb09e4e6f340010bdd522caf85ce92c643343400d86
MISC metadata.xml 682 BLAKE2B 50dc3c55cac525fce3a396c94bdb48eb6e2c0b43636ae53c8ddbce2c9d3f82d8a080d881d4e6ac61ee71f88779c560d38fba3e10424fcd30af0dc80f979df081 SHA512 87e124765948529b7444fb1ad1ae655e18478ca46631a11a6613b289e2ac39600cdc00cc7af82b40694fb1e90c0ccad98be2fb457c5d7f74d5b087a6b3319aff
diff --git a/dev-python/pygraphviz/pygraphviz-1.12.ebuild b/dev-python/pygraphviz/pygraphviz-1.12.ebuild
new file mode 100644
index 000000000000..2dd6e0a3953c
--- /dev/null
+++ b/dev-python/pygraphviz/pygraphviz-1.12.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
+HOMEPAGE="
+ https://pygraphviz.github.io/
+ https://github.com/pygraphviz/pygraphviz/
+ https://pypi.org/project/pygraphviz/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x86-linux ~ppc-macos ~x64-macos"
+
+# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
+DEPEND="
+ media-gfx/graphviz
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/swig:0
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ swig -python pygraphviz/graphviz.i || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/install || die
+ epytest
+}
+
+python_install_all() {
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+
+ distutils-r1_python_install_all
+}