summaryrefslogtreecommitdiff
path: root/dev-python/pygraphviz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-01 01:26:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-01 01:26:02 +0100
commit95ce69d324747e9aa715e1761abab42204529b28 (patch)
treef8e54fe81e25cbaad4488f279c349318b2c18b87 /dev-python/pygraphviz
parentf16e0a3eea2c1d2e5c495ed1802dea365b4fda4b (diff)
gentoo auto-resync : 01:10:2024 - 01:26:02
Diffstat (limited to 'dev-python/pygraphviz')
-rw-r--r--dev-python/pygraphviz/Manifest2
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.14.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pygraphviz/Manifest b/dev-python/pygraphviz/Manifest
index 54ae4ba0efcf..3900bc4eea6d 100644
--- a/dev-python/pygraphviz/Manifest
+++ b/dev-python/pygraphviz/Manifest
@@ -1,3 +1,5 @@
DIST pygraphviz-1.13.tar.gz 104642 BLAKE2B 6111c1b811d5359da673f9c43719d21e86e93e7e82e5819872fed6f87ebb74efb87dba40b5dac737b93bffcd51683f143528a135a76e3d6f62615593fdc22b88 SHA512 3159fd9fb1226974c3a6289ebc437eed394021a7fc41669e29879fa6fd5e5cb809c808a4016cfb1afaf30dc10e467e8b0fe5c3b71fb9a1f889efcf5ae6ff3597
+DIST pygraphviz-1.14.tar.gz 106003 BLAKE2B d56b16c6cc0fefeb258f6071424e20e38277bf76a8750ecbc1d9e2e8af5737ff79c78436bdf0d09c0e785e3b1bf90519b9bfd7014cf8373280c58e7057e2ba19 SHA512 867346303d560be21a37080e6d3ce0afe42119ee373f8cd872e853fee611d2c4cb56cc057023230fcf8ffbf03053ea92b9fc2ec6d5e682d6c6667b6727d87899
EBUILD pygraphviz-1.13.ebuild 953 BLAKE2B 50b118295e392e02bb3431a1ee592ff1b677c85ee79b4ed6325aa55ccdbd81b74177a2f21275bc4a5bb509ff3d0ac060869d14ae185af0e196debbac69a645f2 SHA512 958afbf873fb43f61164e77825a2edfbb566633aa7e9d7412a33577e080c71227465307ffa4813c896257efeb1739bc36f7b0fdd53716bf40aff3e80073d8ff5
+EBUILD pygraphviz-1.14.ebuild 955 BLAKE2B b6a5f4921b2f72fbafb7bb4cb36fc12871e7799e090de4c4159b6ae7f4c887d96d73eda730b035d520c709fc1e7e7fe076c41a640a083bff722e33c4c6431287 SHA512 2df45ea783116e86d506c01345269a08617896adc1df67f2729c32f1e49adca08c84125616732bfe3adfda9199d03dd8274c22c0d3f664ffc8db59acd0a8b4ec
MISC metadata.xml 682 BLAKE2B 50dc3c55cac525fce3a396c94bdb48eb6e2c0b43636ae53c8ddbce2c9d3f82d8a080d881d4e6ac61ee71f88779c560d38fba3e10424fcd30af0dc80f979df081 SHA512 87e124765948529b7444fb1ad1ae655e18478ca46631a11a6613b289e2ac39600cdc00cc7af82b40694fb1e90c0ccad98be2fb457c5d7f74d5b087a6b3319aff
diff --git a/dev-python/pygraphviz/pygraphviz-1.14.ebuild b/dev-python/pygraphviz/pygraphviz-1.14.ebuild
new file mode 100644
index 000000000000..5a9b1b4ec3c2
--- /dev/null
+++ b/dev-python/pygraphviz/pygraphviz-1.14.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
+HOMEPAGE="
+ https://pygraphviz.github.io/
+ https://github.com/pygraphviz/pygraphviz/
+ https://pypi.org/project/pygraphviz/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x86-linux ~ppc-macos ~x64-macos"
+
+# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
+DEPEND="
+ media-gfx/graphviz
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/swig:0
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ swig -python pygraphviz/graphviz.i || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/install || die
+ epytest
+}
+
+python_install_all() {
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+
+ distutils-r1_python_install_all
+}