summaryrefslogtreecommitdiff
path: root/dev-python/pygraphviz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /dev-python/pygraphviz
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'dev-python/pygraphviz')
-rw-r--r--dev-python/pygraphviz/Manifest2
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.7.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pygraphviz/Manifest b/dev-python/pygraphviz/Manifest
index b13efe9e91dc..133decdfc9ca 100644
--- a/dev-python/pygraphviz/Manifest
+++ b/dev-python/pygraphviz/Manifest
@@ -1,4 +1,6 @@
AUX pygraphviz-1.5-docs.patch 929 BLAKE2B 5186201bcbba3485c97c249bf9f4d6b04f641a7ec6db0e8cea9260e8cd4960ab5aeff52ebf81b2bf5dd94be5a0f87b7c10c92cbfc720046f6705e478082b18a5 SHA512 003ed3275771998a40c162abfc61ebf78cb149b20b2b4c770725459364e08a5afb33fe39b00e2e662706a40c3a91033d9e0aead66a7cd627b3b0b2ceba5a62d2
DIST pygraphviz-1.6.zip 117043 BLAKE2B a6c4f28d67ff67bf3fb69869adaad23855c6d702663cfea648b2072b8a5095caaa3d9cfcc864354a362cc6c4c2c6e4a15d5977c58c6af5e22b02f8cea8f7e877 SHA512 6dd389b3fd8c46fd5c8a5a450623f2fe080f720bcf0812618549d092cf917b56ef515f4235fdb89123ece422c6e295705bb08076a3d3e9b193955fcda624acb3
+DIST pygraphviz-1.7.zip 118754 BLAKE2B 36507fc862bec45a33bee3f89e7593a15639e7d98067e1c4ddf917558b7bc037b9d7607f7f017ad5980ba0e6805e63f05464efe8fd416ef70cb95709151714e3 SHA512 09438931d1930a70f7da94b0a12b449c0836ad707c6c8abed49bae0db162c136002d170398ed02dc56a5029269490ce3156d2d4b0f30602a11165bc0038998ea
EBUILD pygraphviz-1.6.ebuild 1042 BLAKE2B 392fc308251b392de90723a947174600ed1f2fd9122ae80614f3c6bada46ec56bc57b912d621d520212c9da4527ad0eb5af73ba07cb8683d9df3ecb1c65bb257 SHA512 a31cb0070dd46767a8703b9c721577e351df72a2e8d1e50f19451528dc997116a4cbff57e859227b2ce9ba4cefbbc47556b2335044bf02aa8b1da3b87a4a3bf5
+EBUILD pygraphviz-1.7.ebuild 1011 BLAKE2B 8cf68c203fc8e94b006dfd8b9b86252238be27496a680ec007b100222e7d685346ed978b7a95c2fadc6e76f1ba7a5b2bf697e0825b69b696f2a4cdbe4f7e56f2 SHA512 d2dd34d45fabf37ff25bca88e2370961bbd1690fc80aa3b5ee7ba5e5bfcb6fb4ededfa12a5fed6390137a4d1843e1d39597804c5757de6bad760d252697d9c08
MISC metadata.xml 616 BLAKE2B 927c4645cd5247ac976860193a6f8024ff122891699c4831a48944cfec51cc5adc55ea0f3eebb873517492146188f6f3eca702f299dcdecfb88f46c0dbf83d8a SHA512 fd9922ce1c9f9d5381c5ed4f4679b45b5bfbb21c452a1ba4064e26fd33e59f648593d7322d1ee68bb4d3e2268a5a8dd2e7f676679d57147929cdb0493835d34d
diff --git a/dev-python/pygraphviz/pygraphviz-1.7.ebuild b/dev-python/pygraphviz/pygraphviz-1.7.ebuild
new file mode 100644
index 000000000000..de88e7c96feb
--- /dev/null
+++ b/dev-python/pygraphviz/pygraphviz-1.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
+HOMEPAGE="https://pygraphviz.github.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos ~x64-macos"
+
+# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
+RDEPEND="media-gfx/graphviz"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/unzip
+ dev-lang/swig:0
+ test? ( dev-python/doctest-ignore-unicode[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ swig -python pygraphviz/graphviz.i || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ epytest
+ rm -rf .hypothesis .pytest_cache || die
+}
+
+python_install_all() {
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+
+ distutils-r1_python_install_all
+}