summaryrefslogtreecommitdiff
path: root/dev-python/pygraphviz/pygraphviz-1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/pygraphviz/pygraphviz-1.7.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/pygraphviz/pygraphviz-1.7.ebuild')
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.7.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/pygraphviz/pygraphviz-1.7.ebuild b/dev-python/pygraphviz/pygraphviz-1.7.ebuild
deleted file mode 100644
index 8d7f82137309..000000000000
--- a/dev-python/pygraphviz/pygraphviz-1.7.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
-HOMEPAGE="https://pygraphviz.github.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 ~riscv x86 ~x86-linux ~ppc-macos ~x64-macos"
-
-# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
-RDEPEND="media-gfx/graphviz"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-arch/unzip
- dev-lang/swig:0
- test? ( dev-python/doctest-ignore-unicode[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- swig -python pygraphviz/graphviz.i || die
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- epytest
- rm -rf .hypothesis .pytest_cache || die
-}
-
-python_install_all() {
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
-
- distutils-r1_python_install_all
-}