summaryrefslogtreecommitdiff
path: root/dev-python/pygraphviz/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pygraphviz/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pygraphviz/files')
-rw-r--r--dev-python/pygraphviz/files/pygraphviz-1.0-setup.py.patch33
-rw-r--r--dev-python/pygraphviz/files/pygraphviz-1.2-avoid_tests.patch47
-rw-r--r--dev-python/pygraphviz/files/pygraphviz-1.3.1-docs.patch29
-rw-r--r--dev-python/pygraphviz/files/pygraphviz-1.3.1-swig-3.patch23
4 files changed, 132 insertions, 0 deletions
diff --git a/dev-python/pygraphviz/files/pygraphviz-1.0-setup.py.patch b/dev-python/pygraphviz/files/pygraphviz-1.0-setup.py.patch
new file mode 100644
index 000000000000..13eb0f213ce1
--- /dev/null
+++ b/dev-python/pygraphviz/files/pygraphviz-1.0-setup.py.patch
@@ -0,0 +1,33 @@
+--- setup_egg.py
++++ setup_egg.py
+@@ -46,7 +46,6 @@
+ download_url = release.download_url,
+ classifiers = release.classifiers,
+ packages = packages,
+- data_files = data,
+ ext_modules = extension,
+ package_data = package_data,
+ install_requires=['setuptools'],
+--- setup.py
++++ setup.py
+@@ -98,12 +98,6 @@
+ sys.path.pop(0)
+
+ packages = ["pygraphviz","pygraphviz.tests"]
+-docdirbase = 'share/doc/pygraphviz-%s' % release.version
+-data = [(docdirbase, glob("*.txt")),
+- (os.path.join(docdirbase, 'examples'),glob("examples/*.py")),
+- (os.path.join(docdirbase, 'examples'),glob("examples/*.dat")),
+- (os.path.join(docdirbase, 'examples'),glob("examples/*.dat.gz")),
+- ]
+ extension = [Extension("pygraphviz._graphviz",
+ ["pygraphviz/graphviz_wrap.c"],
+ include_dirs=include_dirs,
+@@ -130,7 +124,6 @@
+ download_url = release.download_url,
+ classifiers = release.classifiers,
+ packages = packages,
+- data_files = data,
+ ext_modules = extension,
+ package_data = package_data
+ )
diff --git a/dev-python/pygraphviz/files/pygraphviz-1.2-avoid_tests.patch b/dev-python/pygraphviz/files/pygraphviz-1.2-avoid_tests.patch
new file mode 100644
index 000000000000..d444ee3d2df7
--- /dev/null
+++ b/dev-python/pygraphviz/files/pygraphviz-1.2-avoid_tests.patch
@@ -0,0 +1,47 @@
+ pygraphviz/__init__.py | 2 --
+ pygraphviz/agraph.py | 25 -------------------------
+ 2 files changed, 27 deletions(-)
+
+diff --git a/pygraphviz/__init__.py b/pygraphviz/__init__.py
+index a807801..33f727e 100644
+--- a/pygraphviz/__init__.py
++++ b/pygraphviz/__init__.py
+@@ -68,5 +68,3 @@ def version():
+ neato=_get_prog('neato')
+ os.system(neato+' -V')
+
+-# import tests: run as pygraphviz.test()
+-from tests import run as test
+diff --git a/pygraphviz/agraph.py b/pygraphviz/agraph.py
+index c9f735b..90a661e 100644
+--- a/pygraphviz/agraph.py
++++ b/pygraphviz/agraph.py
+@@ -1771,28 +1771,3 @@ class ItemAttribute(Attribute):
+ value.decode(self.encoding))
+ except KeyError: # gv.agxget returned KeyError, skip
+ continue
+-
+-
+-
+-def _test_suite():
+- import doctest
+- suite = doctest.DocFileSuite('tests/graph.txt',
+- 'tests/attributes.txt',
+- 'tests/layout_draw.txt',
+- 'tests/subgraph.txt',
+- package='pygraphviz')
+- doctest.testmod() # test docstrings in module
+- return suite
+-
+-
+-if __name__ == "__main__":
+- import os
+- import sys
+- import unittest
+- if sys.version_info[:2] < (2, 4):
+- print "Python version 2.4 or later required for tests (%d.%d detected)." % sys.version_info[:2]
+- sys.exit(-1)
+- # directory of package (relative to this)
+- nxbase=sys.path[0]+os.sep+os.pardir
+- sys.path.insert(0,nxbase) # prepend to search path
+- unittest.TextTestRunner().run(_test_suite())
diff --git a/dev-python/pygraphviz/files/pygraphviz-1.3.1-docs.patch b/dev-python/pygraphviz/files/pygraphviz-1.3.1-docs.patch
new file mode 100644
index 000000000000..aed5c9075b88
--- /dev/null
+++ b/dev-python/pygraphviz/files/pygraphviz-1.3.1-docs.patch
@@ -0,0 +1,29 @@
+ setup.py | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index fc0a96f..98b7f58 100644
+--- a/setup.py
++++ b/setup.py
+@@ -36,13 +36,6 @@ release.write_versionfile()
+ sys.path.pop(0)
+
+ packages = ["pygraphviz", "pygraphviz.tests"]
+-docdirbase = 'share/doc/pygraphviz-%s' % release.version
+-data = [
+- (docdirbase, glob("*.txt")),
+- (os.path.join(docdirbase, 'examples'), glob("examples/*.py")),
+- (os.path.join(docdirbase, 'examples'), glob("examples/*.dat")),
+- (os.path.join(docdirbase, 'examples'), glob("examples/*.dat.gz")),
+-]
+ package_data = {'': ['*.txt'], }
+
+ if __name__ == "__main__":
+@@ -75,7 +68,6 @@ if __name__ == "__main__":
+ download_url=release.download_url,
+ classifiers=release.classifiers,
+ packages=packages,
+- data_files=data,
+ ext_modules=extension,
+ cmdclass={
+ 'install': AddExtensionInstallCommand,
diff --git a/dev-python/pygraphviz/files/pygraphviz-1.3.1-swig-3.patch b/dev-python/pygraphviz/files/pygraphviz-1.3.1-swig-3.patch
new file mode 100644
index 000000000000..912667e7f5a7
--- /dev/null
+++ b/dev-python/pygraphviz/files/pygraphviz-1.3.1-swig-3.patch
@@ -0,0 +1,23 @@
+ pygraphviz/graphviz.i | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/pygraphviz/graphviz.i b/pygraphviz/graphviz.i
+index 0d9b43b..5f1f6b0 100644
+--- a/pygraphviz/graphviz.i
++++ b/pygraphviz/graphviz.i
+@@ -1,9 +1,9 @@
+-# Copyright (C) 2004-2006 by
+-# Aric Hagberg <hagberg@lanl.gov>
+-# Dan Schult <dschult@colgate.edu>
+-# Manos Renieris, http://www.cs.brown.edu/~er/
+-# Distributed with BSD license.
+-# All rights reserved, see LICENSE for details.
++// Copyright (C) 2004-2006 by
++// Aric Hagberg <hagberg@lanl.gov>
++// Dan Schult <dschult@colgate.edu>
++// Manos Renieris, http://www.cs.brown.edu/~er/
++// Distributed with BSD license.
++// All rights reserved, see LICENSE for details.
+
+ %module graphviz
+