summaryrefslogtreecommitdiff
path: root/dev-python/pygpu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pygpu
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pygpu')
-rw-r--r--dev-python/pygpu/Manifest5
-rw-r--r--dev-python/pygpu/metadata.xml19
-rw-r--r--dev-python/pygpu/pygpu-0.6.0.ebuild38
-rw-r--r--dev-python/pygpu/pygpu-0.6.7.ebuild38
4 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/pygpu/Manifest b/dev-python/pygpu/Manifest
new file mode 100644
index 000000000000..7292abc66640
--- /dev/null
+++ b/dev-python/pygpu/Manifest
@@ -0,0 +1,5 @@
+DIST pygpu-0.6.0.tar.gz 232281 SHA256 a58a0624e894475a4955aaea25e82261c69b4d22c8f15ec07041a4ba176d35af SHA512 ef2b37d7752d7b19e6034ca1992dfa0c82806bae7a15ce54aad785f5abbe06e57a77b804699c55b3b7dc94496afb22acaf3a43cfc15148c150f2c93085c23080 WHIRLPOOL bf702ac1a6f7dd38e59bfc3af3854055730f0ac005ef03b206daf43bab90e930fbe04c8c2765bd673ed3d78b501a5c01f0ba93c22565c99e8aedd6a8049873ac
+DIST pygpu-0.6.7.tar.gz 256440 SHA256 5d3d6f54e53ffe1a43ca86329cf3e5b8b8c1b412cf222df092d741a4de212c2e SHA512 39cdb67ec12d0f939d7a3ebef9726c40e64387413200addbeaf205db4151d09efd90118fec4a71b9d1f81fdde9b52e37d2d97763bf2cc9efa1667c5b9ff716b2 WHIRLPOOL 544c5fd2715c4df9a39c497e4bcef22d95eae8a39f3621d57c3b68ace1e43467855b70209e15b1b8dc08c6a190e14d1307c19084006cddbdb964148442b4453d
+EBUILD pygpu-0.6.0.ebuild 894 SHA256 4798a32c7280d4b063da72d5318f750a0621c1d6d4e793eb0ec908a454439dd7 SHA512 8d04cb413c148f5efca5b72b4397a8e04613430b4f98977d40372de8b8d5e6786c71673d91fdb651a453086b36e19f5ed0f8ace52fb39006b3049a0d74c74b04 WHIRLPOOL 59129594af60cf0cb420107fb8e4607e2326fbf1c141e7584957d3ad186e3472a133360d9d464b45416dd14d8de805ddda7e7d235d183ae4e6e93fd2cf6b4007
+EBUILD pygpu-0.6.7.ebuild 894 SHA256 4798a32c7280d4b063da72d5318f750a0621c1d6d4e793eb0ec908a454439dd7 SHA512 8d04cb413c148f5efca5b72b4397a8e04613430b4f98977d40372de8b8d5e6786c71673d91fdb651a453086b36e19f5ed0f8ace52fb39006b3049a0d74c74b04 WHIRLPOOL 59129594af60cf0cb420107fb8e4607e2326fbf1c141e7584957d3ad186e3472a133360d9d464b45416dd14d8de805ddda7e7d235d183ae4e6e93fd2cf6b4007
+MISC metadata.xml 625 SHA256 a804589ceba06e3def37dab4662767ca727d1ef2ddb32dfd6a1236779f1e648e SHA512 370f27b57bd3815ab8b2f177e8d6755c4a70800c37164c99643a8f2e134acbe259e193d20998e47e521cb8f6c15d1a1703afcdd799499ef79dd4f313335979e2 WHIRLPOOL 287d7d943359a94686b09adbed8f52d18244c0e16ba769c5289311d1caedf9aad73bf808711b0f4a9d10a317016f4d2118b91cd039af57d043f6e77841104104
diff --git a/dev-python/pygpu/metadata.xml b/dev-python/pygpu/metadata.xml
new file mode 100644
index 000000000000..e05423a24848
--- /dev/null
+++ b/dev-python/pygpu/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ This package contains the Python bindings to libgpuarray which
+ are build in the top of NumPy.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Theano/libgpuarray</remote-id>
+ </upstream>
+ <use>
+ <flag name="cuda">Enable NVIDIA CUDA toolkit support</flag>
+ <flag name="opencl">Enable OpenCL support</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-python/pygpu/pygpu-0.6.0.ebuild b/dev-python/pygpu/pygpu-0.6.0.ebuild
new file mode 100644
index 000000000000..71838169b36f
--- /dev/null
+++ b/dev-python/pygpu/pygpu-0.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+MYPV=${PV/_/-}
+
+DESCRIPTION="Python bindings to libgpuarray"
+HOMEPAGE="http://deeplearning.net/software/libgpuarray/"
+SRC_URI="https://github.com/Theano/libgpuarray/archive/v${MYPV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cuda opencl test"
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-libs/libgpuarray:=[cuda?,opencl?]
+"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}/libgpuarray-${MYPV}"
+
+python_test() {
+ local DEVICE=cuda
+ use opencl && DEVICE=opencl
+ nosetests -svw "${BUILD_DIR}/lib/" || die
+}
diff --git a/dev-python/pygpu/pygpu-0.6.7.ebuild b/dev-python/pygpu/pygpu-0.6.7.ebuild
new file mode 100644
index 000000000000..71838169b36f
--- /dev/null
+++ b/dev-python/pygpu/pygpu-0.6.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+MYPV=${PV/_/-}
+
+DESCRIPTION="Python bindings to libgpuarray"
+HOMEPAGE="http://deeplearning.net/software/libgpuarray/"
+SRC_URI="https://github.com/Theano/libgpuarray/archive/v${MYPV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cuda opencl test"
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-libs/libgpuarray:=[cuda?,opencl?]
+"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}/libgpuarray-${MYPV}"
+
+python_test() {
+ local DEVICE=cuda
+ use opencl && DEVICE=opencl
+ nosetests -svw "${BUILD_DIR}/lib/" || die
+}