summaryrefslogtreecommitdiff
path: root/dev-python/pygobject
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-12 06:11:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-12 06:11:51 +0000
commited29ea7e5783aeccaddc89856f6fe75fb78179e5 (patch)
treea99cfbbe9bfaab43efba21c6d77c39216d73118f /dev-python/pygobject
parent8fa69fdd0836c0b856dd0f9ef77d5fb25df844ec (diff)
gentoo auto-resync : 12:03:2023 - 06:11:51
Diffstat (limited to 'dev-python/pygobject')
-rw-r--r--dev-python/pygobject/Manifest2
-rw-r--r--dev-python/pygobject/pygobject-3.43.1.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/pygobject/Manifest b/dev-python/pygobject/Manifest
index ffa9240fd955..7507f9038fd9 100644
--- a/dev-python/pygobject/Manifest
+++ b/dev-python/pygobject/Manifest
@@ -1,3 +1,5 @@
DIST pygobject-3.42.2.tar.xz 558724 BLAKE2B 3e98cf52e818eff42beb8b6120ee8eb4cbe3a6f49670d355e1081b71d411bc93fc701cc37108a321cfcc19698c39b8b61cce5a9369d871da58fd2a2c0455fb96 SHA512 eb604f839e0702e8aeff0f19665e44c05c56cae02ce892e9ab8a95ddb0d5d0216182d0c9a0059fc8e05990c0d5707f2f7456d8924bbfb95ce1d9a42908ac0119
+DIST pygobject-3.43.1.tar.xz 559504 BLAKE2B d8424b34a7945d2ef98bcaff009e5a5555281c187cb8d28cffdcddbec5b16b20619cbb64c3e1ccf23128c4ff4f8187151ca75044977ffb563506085816d886f4 SHA512 e12e53368a94f49daacf24519d9bd65ca11481d6a3059635bebaec43a84d2620fb619c2eac36f7f6b0202a6268b1990f9452355e13b114a4988de18fe30ce66e
EBUILD pygobject-3.42.2.ebuild 1771 BLAKE2B d4fa164835d752652a7521a5e92d7b1e7eff4f8d197ecbf9d183f5e032568bdb010da3c02afcabfb5b7e8166339c2094bbce1b357344a11b804b770b4a6e293b SHA512 ab0bd2dce32f382a21886cb5e5fefc38e410216fd7082e012006fb7b775256a0ed81af954ebdbba90e2d876c60490b159e60a097f7d28379381cbe556260791c
+EBUILD pygobject-3.43.1.ebuild 1793 BLAKE2B b3d6ab5815d171ea86d409cc10a33d837f6ca0271719bad3b9124105fe6ee7d9cba42e770c7d41f551b4e50a27b736ff36f2bc11ee98cb3861bc7eff319f5725 SHA512 3d17f15b0aaa0fbc791c48893c928ccd6dfa0c710255bb90d878e4a89d5af00c96ef10359d9f34095e9add99c9691546881753fc64e15af2d0f71d9fb3601436
MISC metadata.xml 1398 BLAKE2B 0f89629267eea1f03252ac53ebf6478977301f5edf58024152b7e25cac1bb238241d419241dac72181bc82d0bda4dc281fe490a72967b730df7087300562127c SHA512 49ec255944b9530fe59ba325925713512ca84d71149b988c034d092d4a433c6f7a23822d685180c343a40055bb5c879980996d34a30cae8fddc617707bc1a417
diff --git a/dev-python/pygobject/pygobject-3.43.1.ebuild b/dev-python/pygobject/pygobject-3.43.1.ebuild
new file mode 100644
index 000000000000..4973eef2ad38
--- /dev/null
+++ b/dev-python/pygobject/pygobject-3.43.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit gnome.org meson virtualx xdg distutils-r1
+
+DESCRIPTION="Python bindings for GObject Introspection"
+HOMEPAGE="https://pygobject.readthedocs.io/"
+
+LICENSE="LGPL-2.1+"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+cairo examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.56:2
+ >=dev-libs/gobject-introspection-1.56:=
+ dev-libs/libffi:=
+ cairo? (
+ >=dev-python/pycairo-1.16.0[${PYTHON_USEDEP}]
+ x11-libs/cairo[glib]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ >=app-accessibility/at-spi2-core-2.46.0[introspection]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf:2[introspection,jpeg]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ )
+"
+BDEPEND="virtual/pkgconfig"
+
+python_configure() {
+ local emesonargs=(
+ $(meson_feature cairo pycairo)
+ $(meson_use test tests)
+ -Dpython="${EPYTHON}"
+ )
+ meson_src_configure
+}
+
+python_compile() {
+ meson_src_compile
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local -x GIO_USE_VFS="local" # prevents odd issues with deleting ${T}/.gvfs
+ local -x GIO_USE_VOLUME_MONITOR="unix" # prevent udisks-related failures in chroots, bug #449484
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x XDG_CACHE_HOME="${T}/${EPYTHON}"
+ meson_src_test --timeout-multiplier 3 || die "test failed for ${EPYTHON}"
+}
+
+python_install() {
+ meson_src_install
+ python_optimize
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}