summaryrefslogtreecommitdiff
path: root/dev-python/pygobject
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-14 19:44:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-14 19:44:42 +0100
commit4392d53af7ce45ccfe6eb14146479ef0e2bd790a (patch)
tree505de6d6499defff572e53779c70f5fac1118499 /dev-python/pygobject
parent926f46a6d07cdbc78d625b2dfca6a3c27a95b14a (diff)
gentoo auto-resync : 14:10:2022 - 19:44:42
Diffstat (limited to 'dev-python/pygobject')
-rw-r--r--dev-python/pygobject/Manifest2
-rw-r--r--dev-python/pygobject/pygobject-3.42.1.ebuild74
2 files changed, 0 insertions, 76 deletions
diff --git a/dev-python/pygobject/Manifest b/dev-python/pygobject/Manifest
index e2e64dd23a6f..dfab509c28f4 100644
--- a/dev-python/pygobject/Manifest
+++ b/dev-python/pygobject/Manifest
@@ -1,5 +1,3 @@
-DIST pygobject-3.42.1.tar.xz 557904 BLAKE2B 5264c1b187210622548203e0df5089262ea0b3e93d9e46679030b4722e74f1993f200cfe9357c389357902bcdfdb13c8fd9cc9d6efa3b5fa0f730c3b54017fe5 SHA512 b044d395f8334057be632fd56f670ae8405d9fc375bcbd7a0a3b2dcfb8efb06bad45e62e92d2ee5432e503642dba11d6f9bf91f26bf135fa5f9a871657105a18
DIST pygobject-3.42.2.tar.xz 558724 BLAKE2B 3e98cf52e818eff42beb8b6120ee8eb4cbe3a6f49670d355e1081b71d411bc93fc701cc37108a321cfcc19698c39b8b61cce5a9369d871da58fd2a2c0455fb96 SHA512 eb604f839e0702e8aeff0f19665e44c05c56cae02ce892e9ab8a95ddb0d5d0216182d0c9a0059fc8e05990c0d5707f2f7456d8924bbfb95ce1d9a42908ac0119
-EBUILD pygobject-3.42.1.ebuild 1786 BLAKE2B 8da4bf87d753a965f24204363d4250554fceb822bf55090a401ac643d2bd91491ba6dbf3eef57517cfd684350261dc97e73058bf98656a9c92fc3e0dbd84d592 SHA512 aece28c7d33be016887008111abef907eed8d7746559d0527a8a1ef4c46cfde25a2689f620a7b4d4ed4edae332a07630d3b918ac767440b7c91eb892da4dea53
EBUILD pygobject-3.42.2.ebuild 1738 BLAKE2B 86acf53831b915fdb91c6665a5787005eb8f2196550117fc4ea768adc7ac37a9af4473b1830572a4dc2aae350dcae3cc5a61b3fafaa19f7c7b1fca3916d888c0 SHA512 1cb56095da33e487b98d6b87dce49e71d02ef27a41132567bf7a3f1ccc6294a84baad40c69b41323209ccd55d70cd8bf220085102a44271baef4e7373e68b711
MISC metadata.xml 1293 BLAKE2B f47bd4d3e2239697d3684223a8dcfed77c3af429414f6bbbcd6e37d1707d38796fc1ab6ba01402442dbf9cff8d89349888403240ab9dd348083968c61eae5cb8 SHA512 33ad074a03fa3ac7917dc7225218cf8e636776588015c9a9cd9c2274fe77b63a0695f288ff06e0cb94899e5286d11a9746457531df945f8a95fd7e031f601db3
diff --git a/dev-python/pygobject/pygobject-3.42.1.ebuild b/dev-python/pygobject/pygobject-3.42.1.ebuild
deleted file mode 100644
index 95db0a28fc86..000000000000
--- a/dev-python/pygobject/pygobject-3.42.1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit gnome.org meson python-r1 virtualx xdg
-
-DESCRIPTION="Python bindings for GObject Introspection"
-HOMEPAGE="https://pygobject.readthedocs.io/"
-
-LICENSE="LGPL-2.1+"
-SLOT="3"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="+cairo examples test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- >=dev-libs/glib-2.56:2
- >=dev-libs/gobject-introspection-1.56:=
- dev-libs/libffi:=
- cairo? (
- >=dev-python/pycairo-1.16.0[${PYTHON_USEDEP}]
- x11-libs/cairo[glib] )
-"
-DEPEND="${RDEPEND}
- test? (
- dev-libs/atk[introspection]
- dev-python/pytest[${PYTHON_USEDEP}]
- x11-libs/gdk-pixbuf:2[introspection,jpeg]
- x11-libs/gtk+:3[introspection]
- x11-libs/pango[introspection]
- )
-"
-BDEPEND="
- virtual/pkgconfig
-"
-
-src_configure() {
- configuring() {
- meson_src_configure \
- $(meson_feature cairo pycairo) \
- $(meson_use test tests) \
- -Dpython="${EPYTHON}"
- }
-
- python_foreach_impl configuring
-}
-
-src_compile() {
- python_foreach_impl meson_src_compile
-}
-
-src_test() {
- local -x GIO_USE_VFS="local" # prevents odd issues with deleting ${T}/.gvfs
- local -x GIO_USE_VOLUME_MONITOR="unix" # prevent udisks-related failures in chroots, bug #449484
-
- testing() {
- local -x XDG_CACHE_HOME="${T}/${EPYTHON}"
- meson_src_test --timeout-multiplier 3 || die "test failed for ${EPYTHON}"
- }
- virtx python_foreach_impl testing
-}
-
-src_install() {
- installing() {
- meson_src_install
- python_optimize
- }
- python_foreach_impl installing
- use examples && dodoc -r examples
-}