summaryrefslogtreecommitdiff
path: root/dev-python/pygments
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-07 09:24:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-07 09:24:29 +0100
commitfa77846c708f4d0541b610846a5f2ed14b4b20c1 (patch)
tree35860ca9d75749380daddffe86bbd70d3c5866a9 /dev-python/pygments
parent640c4638f1e12a2c71f539ee18564a0c82d19947 (diff)
gentoo auto-resync : 07:08:2023 - 09:24:28
Diffstat (limited to 'dev-python/pygments')
-rw-r--r--dev-python/pygments/Manifest2
-rw-r--r--dev-python/pygments/pygments-2.16.1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pygments/Manifest b/dev-python/pygments/Manifest
index 2057d6c0230b..93a814434c40 100644
--- a/dev-python/pygments/Manifest
+++ b/dev-python/pygments/Manifest
@@ -1,3 +1,5 @@
DIST Pygments-2.15.1.tar.gz 4819591 BLAKE2B f42d3342b88c5b5745fbfbd1f76913f7d17745d396311a39627aca8e968445b19983e7c633583097c495ce6f43a6a7224262a7c35645751803b6c1172062d8c0 SHA512 408f0bbbc8226ee91b82ed084d178f114657150bcf9381dd34debb704399ccdb2e78cb5578ff297797771660d7263c51c305d03b2a27ae29269110be0bca50a9
+DIST Pygments-2.16.1.tar.gz 4872980 BLAKE2B 57ec4f52f2bca3d9df993f583434d61ad0adbc2719f2d0b4ac84160672a3a57ec144509c520f2724a15f0222548abfbe0e743fa31a8dac64d54111b2d7393ae4 SHA512 9b66c79c03e7ecd36cc00efd428a0a6b372e70dbccdcaae26eff4d56c07a17e2e00d2cf0291eb6624ffd1c896b797789b973e80ccbca4240d56daad95eacfd80
EBUILD pygments-2.15.1.ebuild 991 BLAKE2B b21d80e4cbb7457ac40ae37bb8e6e388603181220ff7bd9d10b3f60589989e921438a42c228a0ab21e7eade669e490513f9e5195dea3008544931bcb53b9a195 SHA512 47c02221c98624cae5eb3a176270d0eccac358e980b6aceac9a59404bc796a9990f3cfd50344d48a69294c8fd6bd8b68fc1a5d342c7564632d5cfb459775bae3
+EBUILD pygments-2.16.1.ebuild 1143 BLAKE2B c7952115769c6217dc2924855e93f2e62528f3505c93df2c72a916e41bd2a8c5dc9ecca51161f620eb1783dfa38bd2766ec8708e205888d3f98f53a4e8d99f95 SHA512 52db7e20b58bd41b85b20c77311807de1d377f4b5f87323dc42f6620ccf31d82b06af26a8f4ea63bf7b8810f4c3654ba494492fb785eac7ab32d11c80b1f0499
MISC metadata.xml 618 BLAKE2B fbe7a30ff157e4e13592f96ef8a8b9be60ef2f8e72c08baa56dcca027dde82715b78b3b670ef29190d88dbb582f5cc5fdf9aa2547db5d714c666c28020b54def SHA512 860f398e047e516a8ea4d7fd4e900f1c8efed92422c304e305dc16df9e536ce7be7e06407f93caca0d47f6f929eaa66b2e56acd25105d4f232b841eaca381eb6
diff --git a/dev-python/pygments/pygments-2.16.1.ebuild b/dev-python/pygments/pygments-2.16.1.ebuild
new file mode 100644
index 000000000000..781fe60b07a3
--- /dev/null
+++ b/dev-python/pygments/pygments-2.16.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 bash-completion-r1 pypi
+
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="
+ https://pygments.org/
+ https://github.com/pygments/pygments/
+ https://pypi.org/project/Pygments/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/wcag-contrast-ratio[${PYTHON_USEDEP}]
+ virtual/ttf-fonts
+ )
+"
+
+EPYTEST_DESELECT=(
+ # fuzzing tests, very slow
+ tests/test_basic_api.py::test_random_input
+ # incompatibility with python-ctags3, apparently
+ # https://github.com/pygments/pygments/issues/2486
+ tests/test_html_formatter.py::test_ctags
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp external/pygments.bashcomp pygmentize
+}