summaryrefslogtreecommitdiff
path: root/dev-python/pygments
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/pygments
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/pygments')
-rw-r--r--dev-python/pygments/Manifest2
-rw-r--r--dev-python/pygments/pygments-2.7.3.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pygments/Manifest b/dev-python/pygments/Manifest
index 0b80c6d8beac..a296b167b67e 100644
--- a/dev-python/pygments/Manifest
+++ b/dev-python/pygments/Manifest
@@ -1,3 +1,5 @@
DIST Pygments-2.7.2.tar.gz 2350457 BLAKE2B 4a67cd34cc41402e485e2bbb827a00f5184c00d26ca6f341c190457134598bd1cccc87a995eee85eb007a98b6d7b9e3e33585d0c1c0bba4289bedb36d22f351d SHA512 cd667e2cb33261060c316e3b92934dae735e2aa6c427b77852d4d18f28941cb369da05adb8540dd9fe3262b3e30e2fd6456e345bccc848be9dbdba20e97ef157
+DIST Pygments-2.7.3.tar.gz 2355381 BLAKE2B a7ae0ce7fefd8e2ec707ca8cf2d01d1b746d233e36c78ec51055f750e1a508240b706be50e5f1260f93fe19e15dc27d8de8c614260783713dc61c3c683b86c57 SHA512 fe58ce0beb3d2fd88b374d7864e93dba41e4e2ad6dca570e284fd76615c5bb4e78459a4b8c4dd5f61603d4bccd5705cebafd7274369d158af149e838ec63f7eb
EBUILD pygments-2.7.2.ebuild 957 BLAKE2B 5ba91793dad581672920516e614f0a8b42149e8b7e80c6cd92176b9bea51d60eeaa5e934f6237a9cfc5404ac5f0636a557b717f12980e4529f37751d32894030 SHA512 8fa5d1d43f0230051f3a317f0dd127d789210d162699eb64c2ddfeca3d563fe12d262b31da3ccd39cbb97e4a9b745792f258228b3639276f41f9b8b686f4711e
+EBUILD pygments-2.7.3.ebuild 966 BLAKE2B fa0cf443f46babef9acbd41c69f9c00729f67096fc7a799d7fd7616503eeb53f08abea6dc1164018ea5725c69278e7166dcb77f2f6d36a780fce4f35b80ee449 SHA512 89e82d92a767a1a67e4ec63696c7a453905db1847d660e816a4b730e9c954ee78b2610be456f5119c1bdc57852befa918f7c3b30c54e370fce23ae73c3af74a5
MISC metadata.xml 556 BLAKE2B 87120b6aafeefb97b45a6895b23d08c6443cb177d5bc337845bec55ebdb59ee9eb19ef41c10b3ce4d61452c602f925b4120a441959b5b5d5fea26e15de4a1510 SHA512 b5f4491bb714e2abef07da4e960609aae651ceae3153102467e19bc4d06b9006418729f0b915cc026842253287786faa083d608c0ad5bd7f5c423922740580bd
diff --git a/dev-python/pygments/pygments-2.7.3.ebuild b/dev-python/pygments/pygments-2.7.3.ebuild
new file mode 100644
index 000000000000..d821d49619e3
--- /dev/null
+++ b/dev-python/pygments/pygments-2.7.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1 bash-completion-r1
+
+MY_P=${P^}
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="
+ https://pygments.org/
+ https://github.com/pygments/pygments/
+ https://pypi.org/project/Pygments/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ test? (
+ virtual/ttf-fonts
+ )"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp external/pygments.bashcomp pygmentize
+}