summaryrefslogtreecommitdiff
path: root/dev-python/pyglet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 16:19:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 16:19:32 +0000
commit198bd0cd3c1be97f7deb5283fa00048718482de4 (patch)
tree00169eb129b4ca13ceeb4879c4c5b7fb69c3c4fd /dev-python/pyglet
parente0fac29676c44b996e61c06f8d5c92288e46966b (diff)
gentoo auto-resync : 07:11:2023 - 16:19:32
Diffstat (limited to 'dev-python/pyglet')
-rw-r--r--dev-python/pyglet/Manifest2
-rw-r--r--dev-python/pyglet/pyglet-2.0.10.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/pyglet/Manifest b/dev-python/pyglet/Manifest
index 3760a1b9b204..ef7262a9dbff 100644
--- a/dev-python/pyglet/Manifest
+++ b/dev-python/pyglet/Manifest
@@ -1,3 +1,5 @@
+DIST pyglet-2.0.10.gh.tar.gz 6414679 BLAKE2B 42d6724d67bfac5b80f22f8e995b601dde9e68c49e75b75d1deffb5816ac5a246f0fa5923d159ea27b71720a8301f49dade12ed5179dd4dd69af81085a3daf80 SHA512 cb92e920eebc7b09ccbf396f5a78e5e089df17fbc0cd40b862be9309d97999fcf76995de5602c75efa2294bb387c7489a075fa0bd8ef322ec3573ba6524a3aa4
DIST pyglet-2.0.9.gh.tar.gz 6201289 BLAKE2B 5d79171a1a01087a26a9d02737d6cc1c7bd30d0c7b4266caf211f73a035f26d40495c2aed2090cb4e72b8cd7964b7638c0bd924e0e6bf66db19aecfcac04f455 SHA512 dbaaaa4006b9b92b8d53b5936dc82769c4f2ea203b83fe96952dbfaaba14c1cb877e850c26fb6c1fd4da2580cfc661ff5ea10f30449365dbbfe0307734ba81bd
+EBUILD pyglet-2.0.10.ebuild 1946 BLAKE2B 01c12eb0239550b76cc1de7c8fa648d8637a21c4135f2049dad0bd0c52914298c8ad0dec62d5f3daeb82181b8028e85ff6eb368c8874bc79b3dd4ef1bee047b3 SHA512 59381aeadb4c715a3dd05257fecf7e713b632e19d4fd59359f9a115e52d2561bbbfc1a1b74b8a9b6b46ddbe4666eaf68406b230b11566c4129dc7d30530a918e
EBUILD pyglet-2.0.9.ebuild 1932 BLAKE2B ae4f05e2a19dbd84b78ba5f9c251039c12d79bf90a150180bd39dc3d363dc412a3d45881b45486471eed4b5f98f5139e05e5e950d2046483424426bac13b80c4 SHA512 a3e99310d7dbe718fce3e28cb71632a596b3d1cb5db67120d032afa2b9c4f14cdfecbe4acd87bd1181c66d32db16760eba4b47b26bb7bc1c72aadc60b187ab67
MISC metadata.xml 1092 BLAKE2B 51abba6b5545fb47d277edaca91fda755e885f08a9407f5cd3d468c8b0b86991b57d8d151e27d59755ea884ae894ed0e5c32d357b0d81e66eb9054ca6fc92055 SHA512 7e47cc4c39ebf827bf46423251df994a65c2af8ada9420b36810e36f245bbd810796bc8b02cbce182ff071bbd9dae0c9e5d9f5cb201349cd49fa311b3891dc2f
diff --git a/dev-python/pyglet/pyglet-2.0.10.ebuild b/dev-python/pyglet/pyglet-2.0.10.ebuild
new file mode 100644
index 000000000000..3264295ae589
--- /dev/null
+++ b/dev-python/pyglet/pyglet-2.0.10.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="Cross-platform windowing and multimedia library for Python"
+HOMEPAGE="
+ https://pyglet.org/
+ https://github.com/pyglet/pyglet/
+ https://pypi.org/project/pyglet/
+"
+SRC_URI="https://github.com/pyglet/pyglet/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples image +sound"
+
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-libs/fontconfig
+ )
+"
+RDEPEND="
+ virtual/glu
+ virtual/opengl
+ image? (
+ || (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-libs/gtk+:2
+ )
+ )
+ sound? (
+ || (
+ media-libs/libpulse
+ media-libs/openal
+ )
+ )
+"
+# ffmpeg? ( media-libs/avbin-bin )
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ xdg_environment_reset
+
+ local EPYTEST_DESELECT=(
+ # lacking device/server permissions
+ tests/unit/media/test_listener.py::test_openal_listener
+ tests/unit/media/test_listener.py::test_pulse_listener
+ # fragile to system load
+ tests/unit/media/test_player.py::PlayerTestCase::test_pause_resume
+ tests/unit/test_clock_freq.py::test_elapsed_time_between_tick
+ )
+ if [[ ${EPYTHON} == python3.11 ]]; then
+ EPYTEST_DESELECT+=(
+ # broken test
+ # https://github.com/pyglet/pyglet/issues/606
+ tests/unit/test_events.py::test_push_handlers_instance
+ )
+ fi
+
+ # Specify path to avoid running interactive tests
+ # We could add in integration tests, but they're slow
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest tests/unit || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}