summaryrefslogtreecommitdiff
path: root/dev-python/pygit2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/pygit2
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/Manifest2
-rw-r--r--dev-python/pygit2/pygit2-1.6.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index 30634f3e9571..e9b7470c01da 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1,3 +1,5 @@
DIST pygit2-1.5.0.tar.gz 255958 BLAKE2B 696a4c39920e7f66962b69d2a838c55bfb6f96e7e5ee56a39aaa732926accc3bb6331042382fd22f377959cbc129be0320d94765d13db95fdb7c7f87a14f7608 SHA512 3f915c855ad08641391565906023d231550a38d4e7f8938fad4634a30e2ee1c81e2a0d3289052426e21d2c14814300a0f789eaaa9f3e62c3ece73cf53803bb80
+DIST pygit2-1.6.0.tar.gz 265798 BLAKE2B 8244cbcecdd9b9edcb8fb0cfbc2024f1d36a01c8a3e519e05770ca80d7a482393892bcbd4a61402e7622b84f02909a2a36b9767273d6322a94a15eb974fdb8fa SHA512 c051ce09d227b6ec0c7d3068b5b0220f5c150936d788462dfb3236c97954f9b76f6a1fd61cd42e604810582e3d1a5bc8784fc51c9fedac66ad1b42af580af494
EBUILD pygit2-1.5.0.ebuild 922 BLAKE2B 1194e0c9d03c3fa228c6a42d7bc17ec367d412648ae81b6d25e018d159905ffe90e52ef8f517aba36a71d22291e3b346a92e6867eabb9ef4aa4345277dae2a9c SHA512 03cdfa2c18acfe175da8ed168bbc3202a20141fb3d2094261296b2ce172ac72bd94016f209ff9e4f72f9fba662339e35128c04e8389695269204f294bb616b5b
+EBUILD pygit2-1.6.0.ebuild 925 BLAKE2B 3661015b79daa9bc00d7c5378eb1c540b1652562faddf85ee99ab2c3ec67d15eee66f00deb6ce0ee72e1166ace5dfc4992d478aaebd012f531d78f1eef403d26 SHA512 c1274ce98f9abecd8010e7bbd2a38f7b7ff94c12a9d1cc1a37c59761ef78693d359eef7e26558ea43cbca8725ce468cf2d8455ab06de18fc8ba2f906965a0abe
MISC metadata.xml 489 BLAKE2B 3733ff314640ab2cbfa07e0ea67041ddb3635b51d339070abe97c95b5b358851b412cca5d8996dc1f25abb986a03095f19e8a50cbaeab7eb156c6b9107108cf6 SHA512 d20b7ebbdb3ea2ec72c3c5ded9874b7506b3ddabb43dbf329891478fcf5d7c4b9487ab0675d735733f463dd897dd5cdcc28080ad597f4f838bbcaa565c26915e
diff --git a/dev-python/pygit2/pygit2-1.6.0.ebuild b/dev-python/pygit2/pygit2-1.6.0.ebuild
new file mode 100644
index 000000000000..b69f1d68cbe5
--- /dev/null
+++ b/dev-python/pygit2/pygit2-1.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.org/project/pygit2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-libs/libgit2-1.1*
+ dev-python/cached-property[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditionally prevent it from using network
+ sed -i -e '/has_network/s:True:False:' test/utils.py || die
+
+ # we need to move them away to prevent pytest from forcing '..'
+ # for imports
+ mkdir hack || die
+ mv test hack/ || die
+ ln -s hack/test test || die
+}
+
+python_test() {
+ pytest -vv hack/test || die
+}